Comment to 'How to create a drop-down menu in the Navigation bar?'
  • Hello OneEagle !

    Ok, let's start.

    1) Go to the Studio->Navigation->Sets area.

    2) In the modules list choose the point Custom.

    3) Press the Add button.

    4) In the appeared menu set the name of the new point. For example, Power.

    5) After saving you will see the new Power point in the list. If you were redirected to the all set list then choose the Custom module again.

    6) Click the 0 items link in the Power line.

    7) Add all necessary end menu points there like Point 1, 2 etc.

    8) Go to the Menus area of the Navigation app and press the Add New Menu button.

    9) In the appeared popup for the Set field choose your new Power point. Call this point as Power too.

    10) Back to the Menus area and find your Site navigation menu. Add there the new point.

    11) In the appeared popup for the Submenu field you need to choose your new Power point and enable the Show submenu in popup option.

    The new menu is ready.

    • Hello @LeonidS Thank you for this! It was very easy to follow.


      My problem is that the menu is not displaying correctly, after clearing cache.


      I used the first dropdown style option. How do I fix to display like the main site navigation menu?

      image_transcoder.php?o=sys_images_editor&h=238&dpx=2&t=1648243262

      • Hi @RJ Arsenault It's because you selected 'Site Dropdown Navigation' as a style option in the step #9 of LeondiS's tutorial. I made the same mistake because the name of this optiojn is misleading and doesn't work as expected. It's the first dropdown style option in the list and it happens that it doesn't display the dropdown correctly in the frontend maybe due to some CSS issues in UNA (I don't know, I am just guessing). You should use 'Vertical Links' Style instead as @LeonidS mentioned it in his other.post above.


        To fix it, please go to the Navigation App > Menus. Then Search for the custom menu you created which doesn't display correctly (in your case, it's the menu 'Find'), and edit it by choosing 'vertical Links' Style, not 'Vertical Links (Lite)'. It should work. Hope it helps.