John Curtis
 added a discussion 

Can someone tell me what PHP and MySQL versions work well with UNA 11+.

Thanks, John

  • 183
Comments
  • You can find official requirements here:
    https://github.com/unaio/una/wiki/Requirements

    0 0 0 0 0 0
    • You can find official requirements here:
      https://github.com/unaio/una/wiki/Requirements

      This publication does not cover up to V11. We need it's update Alex T⚜️ 

      0 0 0 0 0 0
      • You can find official requirements here:
        https://github.com/unaio/una/wiki/Requirements

        This publication does not cover up to V11. We need it's update Alex T⚜️ 

        This information should be up to date.

        Why do you think that it doesn't cover UNA 11 ?

        0 0 0 0 0 0
        • Thanks Alex T⚜️

           I see PHP 5.6 (5.5.10 before 10.0.0-B1, 5.5.0 before 9.0.0-RC7) and MySQL 5.5.3 (starting from 9.0.0-RC5) What I'm asking is with UNA 11 is it safe to go with the latest versions?

            PHP 7.4.3 released on 20 Feb 2020 and as of today the latest version of MySQL is MySQL 8.0

          0 0 0 0 0 0
          • You can find official requirements here:
            https://github.com/unaio/una/wiki/Requirements

            This publication does not cover up to V11. We need it's update Alex T⚜️ 

            This information should be up to date.

            Why do you think that it doesn't cover UNA 11 ?

            Well, because it was last updated in July 2019 when V11 was not out and there has been so much talk about 7.1 n 7.2 in this forum.

            0 0 0 0 0 0
            • John Curtis php 7.4.3 should be fine but make sure that when you switch, the needed php extensions are still enabled after you upgrade php versions. I've noticed that some versions of php change extensions used and may disable one that is needed.

              0 0 0 0 0 0
              • Thanks jeremy .

                0 0 0 0 0 0
                • You're welcome. If it doesn't work for some reason, just roll back to previous php version. I am using 7.3 with no issues 7.4.3 shouldn't be much different. You can login to CPanel and screenshot the php extensions currently enabled in case you have to go back or re-enable them upon upgrading.

                  0 0 0 0 0 0
                  • Thanks Alex T⚜️

                     I see PHP 5.6 (5.5.10 before 10.0.0-B1, 5.5.0 before 9.0.0-RC7) and MySQL 5.5.3 (starting from 9.0.0-RC5) What I'm asking is with UNA 11 is it safe to go with the latest versions?

                      PHP 7.4.3 released on 20 Feb 2020 and as of today the latest version of MySQL is MySQL 8.0

                    PHP 7.4 should fine, we've added some fixes for PHP 7.4 in UNA 11

                    0 0 0 0 0 0
                    • You can find official requirements here:
                      https://github.com/unaio/una/wiki/Requirements

                      This publication does not cover up to V11. We need it's update Alex T⚜️ 

                      This information should be up to date.

                      Why do you think that it doesn't cover UNA 11 ?

                      Well, because it was last updated in July 2019 when V11 was not out and there has been so much talk about 7.1 n 7.2 in this forum.

                      PHP 7 is much better for UNA than PHP 5, so feel free to use PHP 7

                      0 0 0 0 0 0
                      Not logged in users can't 'Comments Post'.

                      UNA - Social Media Software Framework

                      Close