• 3 friends

RC12 Update Failure Issue

Hi Everyone, quite awhile, been busy with my launch. Ever since RC12 was released, I have not been able to update from RC11 - 12 both manually and automatically.

I left my Auto Update Setting disabled by default because I always want to be sure its safe to update before I dive in. Just being careful 

I have tried severally on my Tablet and lastly on Laptop now to see its same issue. I tried to enable the "Auto Update" control under "Settings" left it overnight many times, but I realized that it returns itself to DISABLED mode each time I have re-checked.

It has always confirmed "New Setting Successfully Saved" and that server will be updated in a minute but nothing has changed.

I checked if I can get this done in the Database, but couldn't identify the relevant Table.

How do I get around this please? If anyone had same issue ever, please give your voice. Cheers

  • Hello, what is the error message that you receive in your mailbox?

    • Thanks Baloo.

      The error message is:

      "Files copying failed"

        • DeDiary  its better always  with screenshot problem share, which make people to understand easy . 
        •  if you  hosting administrator then enable for display_error   on and will see why error coming  if still not then check error log  maybe  
        • its  come error  just for audio or other stuff too ?

        Regards Ali

        • The error message is "File copying failed" I cant understand the need for screenshot because there was nothing negative ever displayed.

          When I tried manual update it shows "Site will be upgraded in a minute" and nothing happened after.

          I tried to enable "Auto Update" and saved and it displayed "Setting successfully saved" but the next day I checked the setting appeared in Disabled Mode.

          No negative display to capture on screen so far except for message inboxed - File copying failed

          • Hello DeDiary, I think you have a problem of writing rights somewhere, I already had that, it was because www-data could not write a file.

            Unfortunately, the message does not say which one. Do you have this problem for the update of the body? or a particular module?

            • Thanks Baloo, It is for the Core Body and not the Modules. 

              I really dont know what to do now, If I need to contact host, there must be something definite to tell them, but I dont know what.

              What is Alex saying to this, I need to know what and how to fix this.

              • Did you modify rc11 files?

                • NO Baloo, I didnt do any such thing.

                  • The attached is the latest report as I tried once again before this post.

                    The following are the timeline of events on my website from October Till Date.

                    1. The site was upgraded to RC11 on 20th October 2018

                    2. My host notified me of intended plan to migrate my reseller plan to another server scheduled for 26th October that i should suspend any form of update on my website during the said time and I complied.

                    They started and sent me a confirmation on completion some days after.

                    3. I checked the server audit and requested they correct few settings as required for UNA which they did.

                    4. All activities has been okay till this new release came and discovered I cant upgrade.

                    Cant figure where this is coming from really.

                    I never modified anything.

                    • I tried to enable "Auto Update" and saved and it displayed "Setting successfully saved" but the next day I checked the setting appeared in Disabled Mode.

                      After failed upgrade this settings is disabled by the system.

                      My host notified me of intended plan to migrate my reseller plan to another server scheduled for 26th October that i should suspend any form of update on my website during the said time and I complied.

                      It looks like after moving, your site files ownership wasn't set properly, this is the reason upgrade can't overwrite the files. You need to ask your hosting support to fix this problem, files must belong to the same user under which cron is run.

                      • THIS IS STRANGE

                        Hello House

                        I just found that my website hosted on my (MIGRATED) server has lost all update made in the last one month now. 

                        I never complained yet to my host regarding the "Failed Upgrade Issue".

                        Now I found that the site has been Upgraded to RC12 but all major updates from 28th October has been lost, even the latest sign-ups of yesterday.

                        I am trying now to know what possibly went wrong and if I can still get back my lost updates.

                        Thanks

                        • Could you please what changes exactly were lost ? 

                          Usually update don't reset user changes, also if you modify some files, it will not overwrite you changes (however you can force to overwrite it)

                            • All sign-ups from 28th October till date.
                            • Injections of "OneSignal".
                            • All Albums and pictures
                            • All Posts from 28 October
                            • All adjustment to website design
                            • Google AdSense approved 2nd November and inserted to site was removed

                            Its a practical case of RESET

                            I am not a Programmer so, I never dream of file modifications.

                            • ISSUE DISCOVERED

                              My Host Responded With This.

                              >>>>>>>>>>>>>>>>>>>>>>>>

                              Thank you for contacting us. Apologies for the issues you are experiencing.

                              On checking, I noticed your account still points to the old server you were moved from and it appears the updates have been made on the new account as the disk space seems to be larger on the new server.

                              This might have been due to DNS conflicts and I have pointed your domain to the new server with IP. Kindly exercise patience while the propagation completes for your updates to take effect.

                              >>>>>>>>>>>>>>>>>>>>>>>>>>

                              Waiting to see this take effect and also see if the RC11-12 will be resolved.

                              • ISSUE UNRESOLVED

                                The DNS conflict has been corrected with my contents back, but the RC11-12 UPGRADE still impossible.

                                So I now have contents on my old and new servers. The old server actually upgraded to RC12 while the NEW am migrated to, is not UPGRADING hanging on RC11.

                                What do you suggest I should do especially considering the fact that the new server has latest and more content than the old.

                                What do you think is happening here? I cant request that my host carry out another round of MIGRATION. I will be losing a whole month of efforts, new members and content on my website.

                                Please guys I need your advice here.

                                Thanks

                                • Please check if cronjobs are setup properly and I have to repeat my suggestion I gave before:

                                  It looks like after moving, your site files ownership wasn't set properly, this is the reason upgrade can't overwrite the files. You need to ask your hosting support to fix this problem, files must belong to the same user under which cron is run.

                                  • Thanks Alex T.

                                    I will ask the host as advised but please see this screenshot and let me know if your ADVICE above still stand. 

                                    That is the other observation I made as I kept trying to see if this update will go through.

                                    • Regarding the error on the screenshot - I've just checked and there is no such problem, if it happened just once you can ignore it, it maybe just some network problem. If the problem persists you need to ask your hosting provider to investigate this error - particularly why your server can't download this file:

                                      https://github.com/unaio/una/releases/download/9.0.0-RC12/UNA-Patch-v.9.0.0.RC11-to-v.9.0.0.RC12.zip 

                                      • Finally I Found The Missing Link

                                        The root path in the old server was /home2 /ecamp/public_html/....while the new server is /home /ecamp/public_html/.
                                        I had to correct this in the header.inc file in the server.

                                        It was an irresponsible act for my host to have created a non-identical new server architecture when they knew they will be migrating already built projects.

                                        I had to install a "Test Site" on the new server to get the correct Cron Job and also compare the header.inc files to detect this

                                        Now my site is fully upgraded.

                                        Thanks for your attention guys.

                                        12
                                        1
                                        3
                                        4
                                        Added:
                                        Category: