•  · 29 friends

Protean Timeline issues after upgrade - RESOLVED

1. "__item_content_raw__" now appears on all the public feed items.

2. Padding at the very top and bottom of each Timeline entry is off (too wide) .

3. Thumbnails of videos and photos are missing. " __video__ , __image__ "

4. The Follow button is not positioned as expected.

            Any ideas? Help!


rg7fzwkemjqvjyg8ttqsj8gs7fpcnwuw.png

  • 177
Attachments
Replies (29)
  • Hello banister !

    Please specify how the same page look with another template (if you have it). Also please specify if the variable like __video__ , __image__  relate to your own code's customisations.

    •     Hi Leonid and all other kind souls who are offering to help others in far away places.

      I am working with the new 10 beta. Everything seemed to update fine from 9.0.1.

      Yes, the Ocean Template for 10 worked perfectly in every way. So, I deleted my Protean module and installed a fresh one.... but all the problems remain on the Timeline. The Protean template works good with all other modules.

      I cleared all UNA and browser caches, of course.

      Is there some file in the Protean Template or in the TIMELINE module that I can replace? I think it must be a Timeline issue. The phrase "__item_content_raw__" only occurs in the Timeline Module. 

      ( timelline/template/type_post.html )

      How can I replace the Timeline module and not lose all my Cards (entries)?

          Much much thanks. I think a solution is close...

      • It looks like we may have had some similar problems. My protein template had a 7% change which probably caused an issue because that's the module that would not update during the beta upgrade.

        • I would not think it was the Timeline module if everything worked and looked fine when you switched to the Ocean template. It could be what Michael stated above with Protean not getting updated properly. Protean version should be 10.0.0

          For the Like button being all the way to the right now..  That is because of the new "Reactions" that were installed with version 10. You can move that back by going into Studio > Navigation > Choose Timeline form the 1st box and Item Actions in the second one. You will see "Reactions" there. You can move it to where you want it.  

          • Hi Micheal, hey Chris. Thanks for weighing in today.

            I'm on the 10.0.0 version of Protean. It's a module that has been updated many times, btw.

            Things are a little more complicated than it appears - thanks to my "simple" Timeline customization from early 2018. 

            But first note that others do not seem to be having a similar problem... Hmmm.

            More than a year ago, with regard to the Timeline in Protean, some entries put the Title first - others put an image first. Others even put the description before the Title. See the attachment below from 2018. This was driving me absolutely nuts! So, I did change just a little of the html. It may have been fixed in later versions. But it did not break for me until Una 10.

            I would rather just leave things alone and go back to all original than go through these problems. I want to get back to where things can be updated, regardless...

            image_transcoder.php?o=bx_froala_image&h=1488&dpx=2&t=1561658079

            • Oh.. So you made a change to the Timeline module a while back. Since I am not sure what you did, not sure how to tell you to resolve it unfortunately. If it was just a single file, sometimes you can replace that file with the default one. 

              Judging by your screenshot form 2018, it looks like __item_content_raw__ is showing in the new Protean where you used to have an attachment. I assume "Morning Has Broken" is a sound file that was attached. 

              • Yep, I tried to replace the html file where I changed the display order of the Cards but... the file looked to be the same as the old one. Maybe it was already over-written. Oh my, there are many "template" folders, aren't there? I'll have to double check.

                I'm hoping my Database is OK since things were perfect in the Ocean 10 template.

                Still, I would think I could just delete and upload a new Timeline module. Do you think that would work and that I would not lose all my time-line data?

                Maybe Leonid can figure out my error and advise. Again Chris, thanks for caring!


                • You're welcome. Sorry I couldn't help more. What is confusing me is that it looks fine with Ocean. Did you try Lucid too? 

                  • I tried to download Lucid but got an sql error.image_transcoder.php?o=bx_froala_image&h=1489&dpx=2&t=1561662279

                    • I wouldn't download that version anyway.. That version is 9.0.4. You want 10.0.0 I would suggest going into Studio > Apps Market > Click the Search and type in the word Lucid - You should see a version 10.0.0

                      • Ahhh ha, I wondered about that...

                        • Yes, I reinstalled the 10.0 Timeline and.... lost all my data. I had no idea where it was stored. To make it sweeter, as I tried making test messages a few other Cards in the Timeline appeared. Entries from other users, mind you.

                          So, with the new Protean Template and new Timeline module, here is the result:

                            ---- Drumroll ---

                          image_transcoder.php?o=bx_froala_image&h=1490&dpx=2&t=1561665867

                          • I can send you an IM here in there messenger if you want me to take a look to see if there is anything I can do.

                            • Do you think that would work and that I would not lose all my time-line data?

                              You will lose all data, another frustrating about UNA compared to D7, we could back up modules data and then reinstall module then data. Why is this feature not here yet?

                              • All of our site files/data is in the /storage folder and the rest is in the database.

                                • Yeah - Wasn't expecting a uninstall/reinstall of the Timeline Module itself.. at least not just yet. Yikes. 

                                  Banister - I sent you an DM. You should be able to go to Messenger and see it if you haven't already. 

                                  • Of course, I have checked the boxes off for the Timeline as you can see. And cleared the caches.Yes, I did save a copy of the old Timeline Module folder. But the display data must have been in "storage" - now delated.

                                    Thanks everyone who offered advice. 

                                    image_transcoder.php?o=bx_froala_image&h=1491&dpx=2&t=1561667288

                                    • Hi all,

                                      To summarize, it seemed that if I deleted and replaced both Modules - Timeline and Protean - with no customization - it would surely be OK. So I did. But the original problem exists in the Protean timeline on the home page of the site. 

                                      Things are fine in the Ocean 10 Template.

                                      Also, is there anyway to make the Timeline entries (cards) to re-populate? I am not certain if they were deleted because I do not know where they were stored. Do you?  :) I did not see it in the big storage folder - only Timeline photos.

                                      Help me if you can. Thank you. And special thanks to Chris who has gone far beyond the call of duty to look into this strange issue. 

                                      • [27-Jun-2019 00:48:50 UTC] PHP Notice:  Undefined index: src_mp4_hd in /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineTemplate.php on line 1962


                                        [27-Jun-2019 20:30:32 UTC] PHP Fatal error:  Uncaught Error: Call to a member function checkAllowedProfileView() on boolean in /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineModule.php:2524


                                        Stack trace: #0 /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineTemplate.php(177): BxTimelineModule->isAllowedView(Array)

                                        #1 /home/xxx/public_html/xxx.org/inc/classes/BxDolModuleProxy.php(49): BxTimelineTemplate->getItemBlock(3, Array)

                                        #2 /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineModule.php(1326): BxDolModuleProxy->__call('getItemBlock', Array)

                                        #3 /home/xxx/public_html/xxx.org/inc/classes/BxDolRequest.php(97): BxTimelineModule->serviceGetBlockItem()

                                        #4 /home/xxx/public_html/xxx.org/inc/classes/BxDolRequest.php(57): BxDolRequest::_perform(Array, 'BxTimelineModul...', 'serviceGetBlock...', Array, false)

                                        #5 /home/xxx/public_html/xxx.org/inc/classes/BxDolService.php(59): BxDolRequest::processAsService(Ar in /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineModule.php on line 2524

                                        [27-Jun-2019 20:30:38 UTC] PHP Fatal error:  Uncaught Error: Call to a member function checkAllowedProfileView() on boolean in /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineModule.php:2524

                                        Stack trace #0 /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineTemplate.php(177): BxTimelineModule->isAllowedView(Array)

                                        #1 /home/xxx/public_html/xxx.org/inc/classes/BxDolModuleProxy.php(49): BxTimelineTemplate->getItemBlock(3, Array)

                                        #2 /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineModule.php(1326): BxDolModuleProxy->__call('getItemBlock', Array)

                                        #3 /home/xxx/public_html/xxx.org/inc/classes/BxDolRequest.php(97): BxTimelineModule->serviceGetBlockItem()

                                        #4 /home/xxx/public_html/xxx.org/inc/classes/BxDolRequest.php(57): BxDolRequest::_perform(Array, 'BxTimelineModul...', 'serviceGetBlock...', Array, false)

                                        #5 /home/xxx/public_html/xxx.org/inc/classes/BxDolService.php(59): BxDolRequest::processAsService(Ar in /home/xxx/public_html/xxx.org/modules/boonex/timeline/classes/BxTimelineModule.php on line 2524

                                        [27-Jun-2019 20:39:36 UTC] PHP Fatal error:  Uncaught Error: Call to a member function genDbCacheKey() on null in /home/xxx/public_html/xxx.org/inc/classes/BxDolLiveUpdates.php:190

                                        Stack trace:

                                        #0 /home/xxx/public_html/xxx.org/inc/classes/BxDolLiveUpdates.php(197): BxDolLiveUpdates->_getCacheInfo()

                                        #1 /home/xxx/public_html/xxx.org/inc/classes/BxDolLiveUpdates.php(225): BxDolLiveUpdates->_getCached('systems')

                                        #2 /home/xxx/public_html/xxx.org/inc/classes/BxDolLiveUpdates.php(102): BxDolLiveUpdates->_getCachedSystems()

                                        #3 /home/xxx/public_html/xxx.org/live_updates.php(16): BxDolLiveUpdates->perform()

                                        #4 {main}

                                          thrown in /home/xxx/public_html/xxx.org/inc/classes/BxDolLiveUpdates.php on line 190

                                                                                 ???     : (

                                        • I am hoping that someone from the UNA team can help you out here. When I looked at your site, it was not accepting changes I made and acting strange. Not sure but maybe some files didn't get updated properly. Very strange. 

                                          • Update: Yes indeed, the Team came to my rescue even though they are overwhelmed with work at this crucial time in UNA history. 

                                            My issues were self-inflicted and now resolved. I had made minor changes in the html layout, you see. This caused the updates to gag.

                                            Hey people, please learn from my mistakes! And if you have to modify something, try to add it via the Custom Styles in your template mix.

                                            • Anyone know how to fix this issue in image below


                                              • It was happening all over the place in PROTEAN theme only, and we updated that theme and most of the issues were resolved , however now all themes/ templates are doing and showing this after comment is made 

                                                • And why can’t I post links here? I’ve purchased multiple pro packages 

                                                  • Hi Presser, I had multiple issues which affected Protean. The one similar to yours was fixed via a new install of Protean. After the deactivation and deletion of my corrupted version. 

                                                    You cleared your caches, right? Both UNA and browser?

                                                    Good luck.

                                                    • You can post links once UNA updates your status or membership level (Standard), which they will. This issue has come up several times before. Yes, it is an aggravation but can easily be fixed. It is a spam-prevention measure, of course. Contact support.

                                                      • I still can not figure out how to fix this issue

                                                        • I've been there and know how frustrating this situation is to be so close to a fix. 

                                                          You should start a new thread since this issue has spread beyond Protean. And the title becomes misleading.

                                                          Good luck!

                                                          • Presser - FYI - That screenshot you post was not of Protean. That is Decorous template. As Banister said, you may want to start a new thread regarding your issue. 

                                                            14
                                                            8
                                                            1
                                                            3
                                                            4
                                                            Labels:
                                                            Added:
                                                            Category: