•  · 8 friends

Video file not processing

Hello guys,  my video file not processing. So, I ask my hosting company to fix the problem.  They try all what they can do and they come out with this.  I am pasting what they email to us. Anyone can help me with this please. I have to fix this ASAP. So, please read below

We have reviewed the reviewed your application in detail and here are the changes we have performed up until now:

  • We have enabled exec() and shell_exec() in the PHP-FPM Configuration file for your website, as both of those PHP Functions are required for FFMPEG Commands to be executed server-side
  • We have changed the permissions of the internal ffmpeg.exe file of your UNA Application to 777 so it has full permissions for all User Groups
  • We have modified the Cron Job that is being executed to a different PHP Binary, as it seems that the current path that is set is not correctly executing the command, and now it is the following:

/opt/cpanel/ea-php56/root/usr/bin/php [path to UNA]periodic/cron.php

Upon attempting to execute the Cron Job, in order for it to start processing the Videos, the following error message in the coding of UNA's Video Transcoder appeared:

Fatal error: Call to a member function getDb() on boolean in [path to UNA]inc/classes/BxDolTranscoder.php on line 119

Please note, however, that this is an issue with the core PHP Coding of that file, and resolving this issue is beyond our expertise as a hosting provider, therefore, we kindly ask you to forward this information to your developer so he can assist you in resolving this.

Once this issue has been taken care of, the videos should start processing without any issues, as there aren't any server-side configurations that need to be taken care of.”

What do I do next guys?

Thank you


0 0 0 0 0 0
  • 345
Replies (17)
  • Hello Senthur !

    The shown error means that this line in inc/classes/BxDolTranscoder.php:

    $o = self::getObjectInstance($r['transcoder_object']);

    gives the wrong object. You may try to execute the following query in your UNA database (you may backup this table before):

    DELETE * FROM `sys_transcoder_queue` WHERE `status` = 'processing';

    and try to upload the new video again. Then check the new result.

    0 0 0 0 0 0
    • Thank you I try this

      0 0 0 0 0 0
      • Are you can help to setup my video processing.  My hosting company can’t fix it. Tmdhosting recommened from boonex but they have no idea how to fix.  So, una can help me to fix the video?

        Thank you

        0 0 0 0 0 0
        • It maybe some records left in transcoder queue which cause this error, I would suggest to clean transcoder queue:

          DELETE * FROM `sys_transcoder_queue`

          and then try to upload some video again

          0 0 0 0 0 0
          • Thanks for the message. I reinstall the una.  Is working now.

            Thanks again.


            0 0 0 0 0 0
            • Here is what TMD hosting sent me:

              Please note that the issue is related to the status of the videos not automatically changing.

              For example, when uploading a video, it transitions between multiple states:


              For some reason, some of the videos are getting stuck in the Pending process, even though there should be no issues with their conversion.

              Once a video gets stuck in the Pending state, all of the additionally uploaded videos would get stuck as well, until the issue has been resolved.

              To resolve the issue, we enter the website's database and manually alter the state of the video.

              Unfortunately, this issue is not server related and we would not be able to determine how to permanently resolve it.

              You could consider contacting UNA's support regarding the matter and request more information on how to potentially resolve the issue.

              Please do not hesitate to contact us again, if we can be of any further assistance.

              Our team is 24/7 at your immediate disposal!

              Best Regards,

              Nigel Clark
              Technical Support Team

              0 0 0 0 0 0
              • Is there a permanent fix for this?

                0 0 0 0 0 0
                • OwnerOps please note the following:

                  1) never change status of files in transcoder queue it may lead to unpredictable results

                  2) check if remote transcoding option isn't enabled Developer > Settings > Remote video transcoding, it requires special setup

                  2) original issue was related to the problem when some webm files left in queue after webm transcoders were removed in some of previous updates, then clearing transcoding queue should help - https://una.io/cmts.php?sys=bx_forum&id=3869&cmt_id=15645

                  0 0 0 0 0 0
                  • For someone new could you please describe how to clean the transponder queue?

                    0 0 0 0 0 0
                    • What is the permanent fix to stop this from happening?

                      0 0 0 0 0 0
                      • For someone new could you please describe how to clean the transponder queue?

                        You need to run the following query:

                        DELETE FROM `sys_transcoder_queue` WHERE `transcoder_object` LIKE '%webm' AND `status` IN('pending', 'processing', 'delete');

                        You need to do it only once, no need to do it periodically.

                        0 0 0 0 0 0
                        • It looks like this is not working.  I ran the query and also deleted all videos and started posting videos again but always get stuck after my third video.  4th video stays stuck in processing.  

                          0 0 0 0 0 0
                          • Thank you for the help but it did not fix the issue.  4th video always gets stuck in processing.

                            0 0 0 0 0 0
                            • I tried running the query but this fix did not work. It seems the 4th video I am trying to post always gets stuck in the processing mode.

                              0 0 0 0 0 0
                              • Here is the reply I got back for TMD hosting:


                                Thank you for the update.

                                It appears that the written query is not suitable for this version of MariaDB:

                                MySQL said:

                                1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '%webm’ AND status IN(‘pending’, ‘processing’, ‘delete’)' at line 1

                                We have reviewed the MySQL Documentation in an attempt to locate what syntax should be used for your version of MairaDB (10.2.27-MariaDB) - to no avail.

                                You should possibly contact a database specialist or the team behind UNA, for the proper syntax that should be used for this version of MariaDB.

                                Additionally, we cannot be certain why this issue would occur, given that all server requirements for the UNA script are beyond covered.

                                Kind Regards,

                                Jared Levine
                                Genius Support Team

                                0 0 0 0 0 0
                                • What is your server plan with TMD? Shared? Virtual? Dedicated?

                                  Shared plans with TMD will result in much frustration with regard to video processing. I write this to warn others.

                                  Please check your server cpu and memory usage on your Control Panel. If there is a spike while processing a video, that brings the process to a halt with TMD shared plans. 

                                  A 2 or 3 minute video is tops. 

                                  Please keep us informed, Owner Ops - this is an ongoing discussion. 

                                  A social site without video has little to offer.

                                  0 0 0 0 0 0
                                  • I have VIP server.  I having same problem too.  It’s only happening after, upgrade too new version of UNI.   I spend more than one month with TMD.  They couldn’t fix this problem. TMD don’t have any idea about this. Waste of time with TMD.  I reinstall fresh copy of 10.1 in new folder.  That the solution for now.  The video uploading good. And, don’t upgrade until find the  new solution.  Anyone know how to fix, please let me know.
                                    thank you guys

                                    0 0 0 0 0 0
                                    Not logged in users can't 'Comments Post'.

                                    UNA - Social Media Software Framework