•  · 13 friends

Set Membership Button Missing

Someone to whom I recommended UNA, is trying it out but ran into a snag after it was installed using Softaculous.

The set membership button does not show on profile pages.

The admin of the site appears as a standard member only and cannot do certain things because of that. After signing in using the admin credentials, the admin is like a standard member.

Is there some information on how to change the admin member from standard to administrator?

I did a search but could not find a listing which discussed this.

0 0 0 0 0 0
  • 643
Replies (34)
  • Studio > accounts

    0 0 0 0 0 0
      • Will Monte, that goes nowhere. how to make the set membership button appear on profile pages and especially how to make the admin as administrator rather than as standard after signing in with the admin credentials.
      0 0 0 0 0 0
      • Ok, what about going to studio > navigation > person more

        0 0 0 0 0 0
        • There is nothing there about the membership button appearing on the profile pages for someone signed in as admin. I appreciate your help.

          0 0 0 0 0 0
          • Alexey can you help here

            0 0 0 0 0 0
            • see diagram

              1 --- set membership button missing

              2 --- this is the admin signed in but show the admin as standard member and not as administrator

              0 0 0 0 0 0
              • You don't have what i'm pointing out in the picture?

                0 0 0 0 0 0
                • I do not have that. It is missing and also the admin is listed as standard member rather than as administrator. By admin I mean signing in with the admin credentials which gives access to the studio

                  0 0 0 0 0 0
                  • Well, you can make changes like i mentioned above to go to studio > accounts > and to far right the setting wheel, see picture

                    0 0 0 0 0 0
                    • Geek Girl LeonidS can i get some help here or Baloo 

                      0 0 0 0 0 0
                      • image attached of what happens at studio>accounts

                        0 0 0 0 0 0
                        • You don't see a settings wheel to the far right for each user?

                          0 0 0 0 0 0
                          • to the far right there is only  Last Logged as in image attached

                            0 0 0 0 0 0
                            • Who or how did you install UNA?

                              0 0 0 0 0 0
                              • It was installed for a friend of mine by TMDhosting but they used softaculous to install it. The person asked me to look at it as they are trying out UNA for the first time.

                                0 0 0 0 0 0
                                • Hello eveybody!

                                  Here you may see how to manually create operator via Database so you need to set `role`=3 to change the present status of the user.

                                  0 0 0 0 0 0
                                  • Same problem. UNA-v.10.1.0 install, self hosted (Ubuntu 18.04 + LAMP) has been bugging me for some time how to I make another user Admin, Moderator etc.. but now I see why I couldn't find. Set Membership button is missing!!

                                    The database fix didn't work for me?!

                                    It gave the user more privileges but the Set Membership button still not there.

                                    Any ideas??

                                    0 0 0 0 0 0
                                    • we are talking to TMDhosting about this because they installed it in the first place using softaculous but we did try to database fix and that failed. We used phpmyadmin. Right now we are waiting to hear from TMDhosting. Will report back as soon as we get a solution, unless something else is posted here

                                      0 0 0 0 0 0
                                      • As I'm self hosted I have full access to my server and did a manual installation. I didn't receive any errors or issues during installing so had no indication there was a problem.

                                        0 0 0 0 0 0
                                        • You want to create another account?

                                          0 0 0 0 0 0
                                          • Subparticles control the world, while humanity fumbles around!

                                            0 0 0 0 0 0
                                            • TMDhosting coped out:

                                              Our expertise does not extend to in depth customization of the application itself, you would need to contact a developer who would be able to further assist you with this.

                                              Considering this, we believe that it would be best to contact an expert developer with a better understanding of this concern.

                                              I thought of uninstalling it and manually installing but if roonster manually installed and has the same problem, I feel it would be a waste of time

                                              0 0 0 0 0 0
                                              • Any idea anyone ??

                                                I’ve no Set Membership button when using installed administrator or user set as operator via the database ??

                                                0 0 0 0 0 0
                                                • Update after checking the site of Michael Beloved !

                                                  There were no records in the table `sys_acl_levels_members` which indicates assigned levels to profiles. So if you have the same situation you may try to execute the following query in your UNA database:

                                                  INSERT `sys_acl_levels_members` (`IDMember`, `IDLevel`, `DateStarts`) VALUES(__profile_id__, __level_id__, '2019-10-25 00:00:00');

                                                  where:

                                                  __profile_id__ - id of admin profile (can be found in the field `profile_id` from the table `sys_accounts`)

                                                  __level_id__ - id of administration level (by default 8, but can be specified from the table `sys_acl_levels`)

                                                  0 0 0 0 0 0
                                                  • LeonidS solved the issue for me. If anyone used Softaculous and has the problem, please state what happened.

                                                    0 0 0 0 0 0
                                                    • I checked and my `sys_acl_levels_members` table is also empty. Strange thing is I have 2 separate installations and the table is empty in both (the Set Membership button is also missing in both also). 

                                                      Could this be an installation issue?

                                                      How should the table look and how is it normally populated?

                                                      Should there be a separate row for each site member with the appropriate level set or just administrators?

                                                      Also site member are seeing the following message when trying to access content they should have access to.

                                                      Access denied. This is private content.

                                                      For instance access to another Profile when the 'Visible to' is set to a level that includes them (e.g. Relationships).

                                                      Is this issue related the the  `sys_acl_levels_members` being empty?

                                                      0 0 0 0 0 0
                                                      • Hello r00nster !

                                                        Could this be an installation issue? 

                                                        Perhaps, need to check right after the installation. As admin profile is the profile too then he should have the assigned mem levels as others.

                                                        Should there be a separate row for each site member with the appropriate level set or just administrators? 

                                                        Yes, every profile has the own record about his permissions levels (Administrator, Standard etc).

                                                        Access denied. This is private content. 

                                                        This message appears when the viewer hasn't rights for action or the records about his mem levels are missing (the problem above, in this case, he is a guest).

                                                        0 0 0 0 0 0
                                                        • Updating 'sys_acl_levels_members' as instructed has made no difference!

                                                          I still have below problems...

                                                          1. I don't see a settings wheel to the far right of each account in Studio>Accounts  

                                                          2. In the Home view users only see content from other members who have their "Visible to = Public". Content from members with it set as Friends or Relationship do not show (even though they are Friends & Relations to the other user). The missing content shows up in the Dashboard view though! 

                                                          3. Profiles from Friends/Relations cannot be viewed (Access denied. This content is private) unless the 'Visible to" is Public 

                                                          If the 'role' column in 'sys_accounts' table is set to 3 (Operator) users are not effected by 2 and 3 above.

                                                          So it seems all users are being treated as Guests unless the 'role' in sys_accounts is set to 3 but no idea why Studio>Accounts not showing the settings wheel (I tried different Browser incase it was that).

                                                          0 0 0 0 0 0
                                                          • LeonidS, I noticed that when using Softaculous to install UNA whatever is put in the admin account credentials, disappears after saving. It does not hold. However in a previous install using Softaculous some months ago, it did not act like this.

                                                            I suggest that one of your staff should make a trial to see if when using Softaculous this happens and also when installing by other methods, manually or otherwise.

                                                            0 0 0 0 0 0
                                                            • So I've figured out the first issue.

                                                              When I installed the site I used a different email/account for the 'Admin' and created a separate account I used for my normal access later on. As the Admin user/account wasn't intended to create any content within the site (just purely to manage the site) I didn't bother to create a 'Persons' profile for the site Admin account.

                                                              Creating a Persons profile for the Admin account (created at installation) and I can now see the settings wheel in Studio>Accounts and "Set Membership' when I view a profile of another account.

                                                              But..

                                                              For members content from Friends/Relations is still not showing in Home view and members cannot view other members Profiles unless visibility set to Public (2 and 3 above).

                                                              Is there someway of fixing these other issues?

                                                              0 0 0 0 0 0
                                                              • r00nster's discovery is great. I suggest that UNA should clarify this for future reference with some tutorial or step-by-step article which explains this clearly. Otherwise it means that some installers will spend hours trying to figure this out. Better yet, if is alerts pop up when the site is open first after installation, which guide the admin through this UNA jungle.

                                                                I spend hours on this and still I am not sure that I understand it, besides know that it can be fixed.

                                                                0 0 0 0 0 0
                                                                • Hello r00nster !

                                                                  Thnx for your checks too. The "create profile" action makes the same action as my SQL commands shown above. But in Michael Beloved the admin's profile was completed, the deal was just in missing records for `sys_acl_levels_members`.

                                                                  About friends content - yes, the content with this level of visibility will not be shown in public blocks.  

                                                                  0 0 0 0 0 0
                                                                  • Thanks for the replies. This still doesn’t sound right. Maybe I wasn’t clear enough outing the problem. 

                                                                    if iI configure my profile as follows 

                                                                    Visibile to = Friends (or Relationships)

                                                                    Who can post to my profile = Public

                                                                    Then create a new post (to Posts, Timeline etc..)  and in the post set Visibility = Public

                                                                    My post doesn’t appear in Home screen content even though it is marked as Public. but does show in  Dashboard content. Also when a Friend/Relation tries to view my profile they get Access Denied - This content is Private.

                                                                    If my profile is set as follows

                                                                    Visibile to = Public

                                                                    Who can post to my profile = Public

                                                                     

                                                                    Then Posts with Visibility = Public show up in both Home and Dashboard content and members can view my profile (But so can anyone)

                                                                    0 0 0 0 0 0
                                                                    • It is interesting situation with Friends and private content. Please provide me your UNA studio access via Messenger, I'll review it.

                                                                      0 0 0 0 0 0
                                                                      Not logged in users can't 'Comments Post'.
                                                                      14
                                                                      5
                                                                      7
                                                                      9
                                                                      Added:
                                                                      Category:

                                                                      UNA - Social Media Software Framework

                                                                      Close