•  · 27 friends

major malfunction unknown with images, videos...

so last night I installed the plyr extension.  was pretty excited.

then i went to test it.   post will be posted after conversion.  okay ! cool...

20 minutes later nothing.  i tried again.  nothing.  small video.  70megs.

tried two more smaller videos.  nothing.  got curious.  changed ffmpeg to a static clean build from ffmpeg.org and changed path in header , yes it was readable.   nothing.

changed header back to ffmpeg.exe prebundled.

but in the meantime noticed images ceased to upload to my site.  and videos too.  


uninstalled playr.  still images are not working and still videos are not working.

they dont even work in jot messenger anymore.  and i have NO idea what happened or how to fix it.


and now that we're up to about 70 people on the site, people are going to notice soon.  what do I do ?

just for good measure, i rebuilt all the tables in the entire database, using phpmyadmin, for mysql.

did not help.


what is strange is this - the image or video appears to upload, and then it pastes in my protean colors for the menu background and the menu bar in the uploadify background...  see image.

💓0 😆0 😲0 😥1 😠0 0
  • 743
  • More
Attachments
Replies (38)
    • Will Monte , Baloo , have you ever done this to your site by accident?  I dont even know how this happened.. =( 

      💓0 😆0 😲0 😥0 😠0 0
      • Will Monte , Baloo , have you ever done this to your site by accident?  I dont even know how this happened.. =( 

        Hey Omar Amer , i'm actually working over in NY and in the middle of something important, using my cell to reply here. Try to get Baloo or Chris to help you here. They both are online, sorry brother!

        💓0 😆0 😲0 😥0 😠0 0
        • right on ! no worries !  thank you Will !               @hi Chris :)  Has this ever happened to you or do you know what I should be fixing?  :)

          💓0 😆0 😲0 😥0 😠0 0
          • This Is kind of the same issue Im having. Everything works great "except" videos. It sits there continously saying converting video, etc. I also tried here at UNA.io, with the same result...

            I have tried, from PC, Laptop, Tablet and mobile. they all get the same result, with a continuous converting video.

            My audio and file uploads are working flawlessly....

            This is what it does with a 8.5mb video for hours:

            image_transcoder.php?o=bx_froala_image&h=3417&dpx=1&t=1587152999

            💓0 😆0 😲0 😥0 😠0 0
            • yeah thats what it did to me.  even a 20 meg video.   i do a lot of encodes with ffmpeg regularly, and know it to be *quite* robust and extremely fast.  a 20 meg transcode should take about 15 seconds.  


              did you also have the ability to upload photos go absolutely bezerk afterwards?  

              i'm now getting "invalid server response" when i try to send a photo on jot as well.

              this is frankly making me rather upset.  

              💓0 😆0 😲0 😥0 😠0 0
              • No... My sounds, and files uploads are doing great. I did have to have my server people make some adjustments to my overall file size amounts, server side. Once that was done I had no issues with those. I have had the video issue continuously. I to am having members who are wanting to upload video, but they get the same result as you or I. (A continuous converting window). I have been at this problem for over 3 weeks now. 

                It is a bit upsetting for sure.

                I have found today though, that the problem is relevant and persistant here on UNA.io, as well.

                💓0 😆0 😲0 😥0 😠0 0
                • Just to rule out some things, for videos to work make sure that:
                  1. ffmpeg.exe is set to executable (777 - permission)

                  2. Your cron job is setup and working properly

                  3. Your post_max_size and upload_max_size settings are set properly

                  4. You have enough memory_limit is set high enough (i.e. 256MB or 512MB)

                  Also note that the ffmpeg.exe version that is bundled with UNA is for Linux so, if you have a "Windows" server, you will need to get the ffmpeg.exe version for windows. 

                  💓0 😆0 😲0 😥0 😠0 0
                  • Chris

                    Can you upload a video here on UNA? I've even tried this and get the same result. So it seems to not be related to something on my end. At least so it seems.

                    💓0 😆0 😲0 😥0 😠0 0
                    • yes to all of the above.

                      :)

                      777 and executable

                      cron job is working correctly.

                      post max size 600M, upload max size 512M and yes with underscores.. :)
                      memory limit is 512.

                      no, no offense to the windows crowd, but you would have to bury me in sand to get me to run a windows server.  its linux.  :D

                      💓0 😆0 😲0 😥0 😠0 0
                      • HAHAHA. Do you have any "Failed" in your server audit? Studio > Dashboard > Host Tools > Server Audit

                        💓0 😆0 😲0 😥0 😠0 0
                        • lemme test one ... 


                          💓0 😆0 😲0 😥0 😠0 0
                          • nope, nuttin'   i deleted the posts in case they went in a single thread que.

                            💓0 😆0 😲0 😥0 😠0 0
                            • That prompted me to download it since you added it as an attachment.


                              💓0 😆0 😲0 😥0 😠0 0
                              • on my site so far i've been using iFramely codes for videos ive hosted on a different domain but on the same webserver.   those work fine.   then i install "plyr" last night.  and tried to upload a video from the local drive, and then the encoding wait thing happened, and all hell broke loose, now i cannot even upload  a still image to my site.  which.. is most puzzling.  it shows it will be uploading, and then at the end of the progress this happens...   and if i hit close, the whole page has a white half transparent overlay, and if i hit reload it's all erased.  very strange.

                                💓0 😆0 😲0 😥0 😠0 0
                                • You guys are something else...lol

                                  I'm in the city and all I hear is beep...beep...beep....lol

                                  💓0 😆0 😲0 😥0 😠0 0
                                  • Stop focusing on us Will Monte and get back to work 😆 😆 😆 😆 

                                    💓0 😆0 😲0 😥0 😠0 0
                                    • Will Monte whatever you do never get on facebook, your life would be over. 😆

                                      get to work 😁🕳

                                      💓0 😆0 😲0 😥0 😠0 0
                                      • No we are not cussing, lmao!

                                        💓0 😆0 😲0 😥0 😠0 0
                                        • Lol........you guys have no idea how much I wanted to crack the fudge up a bit a go. Im outy....lol

                                          💓0 😆0 😲0 😥0 😠0 0
                                          • DING DING DING DING DING DING DING DING DING DING DING

                                            💓0 😆0 😲0 😥0 😠0 0
                                            • Videos on UNA simply doesn't work well right now. Whatever the case may be. I just don't use it on my platform.  Either that or build your own custom module that handles it. 

                                              💓0 😆0 😲0 😥0 😠0 0
                                              • i'm gonna go out on the logical limb here and say the following very matter o factly., but without any anger in my words-

                                                if the button is there, it should work.
                                                if it doesn't work yet, the button is not ready to include in production, and should be marked clearly as "experimental, testing, or beta"

                                                okay so ..

                                                what do we know?
                                                uploadify exists in the plugin architecture included with una.
                                                a storage folder exists.
                                                storage folders for videos exist in the storage architecture tree, and have mysql entries.

                                                what is the actual issue?

                                                i didn't even realize this was a problem until a few site users requested "youtube style functionality," and I realized I'd been posting all my videos via SFTP, to another user directory, and then posting with embed codes. normal people do not open the source code and paste an embed from a developer api.

                                                so, we have a problem that needs to be collaboratively solved.

                                                lets handle it.

                                                💓0 😆0 😲0 😥0 😠0 0
                                                • Will Monte whatever you do never get on facebook, your life would be over. 😆

                                                  get to work 😁🕳

                                                  lol....i know...lol

                                                  💓0 😆0 😲0 😥0 😠0 0
                                                  • Stop focusing on us Will Monte and get back to work 😆 😆 😆 😆 

                                                    LOL

                                                    💓0 😆0 😲0 😥0 😠0 0
                                                    • DING DING DING DING DING DING DING DING DING DING DING

                                                      LOL

                                                      💓0 😆0 😲0 😥0 😠0 0
                                                      • hahahahaha

                                                        💓0 😆0 😲0 😥0 😠0 0
                                                        • okay, i checked the apache error log the vhost shoots into the home dir along with analog stats and the https queries for the relevant vhosts home directory...


                                                          i found some very interesting thing about collections and modSecurity... 

                                                          and a bunch of similar entries..  this could be part of the problem, or perhaps not.

                                                          but anytime there are errors, they are worth looking at


                                                          image_transcoder.php?o=bx_froala_image&h=3423&dpx=2&t=1587213288

                                                          💓0 😆0 😲0 😥0 😠0 0
                                                          • okay ive disabled apache mod security, and rebooted the web server, cleared una's caches...

                                                            uploaded a new test video.. and tis been enqueed for 35 minutes..   an 85 meg video.


                                                            still not working .....


                                                            Chris , what should I be checking ?  not doing anything fancy, just using the video upload button... all php settings are significant, and well, i just would like this to work, i'm fine using iframe codes and sftp'ing videos but the people want this feature badly.  :)  I get asked about twice a week about it.

                                                            💓0 😆0 😲0 😥0 😠0 0

                                                            • img 1: shows waiting for one hour

                                                              img 2: what i see in the manage posts

                                                              img 3: timeline without post not included, for it is anti-climactic. 😊

                                                              image_transcoder.php?o=bx_froala_image&h=3426&dpx=2&t=1587252508image_transcoder.php?o=bx_froala_image&h=3427&dpx=2&t=1587252525

                                                              note: i'm starting to wonder if grsec2 needs a rule about the path to the static ffmpeg.exe binary.. theres already a inherit learn rule about cron, for cron scripts that get passed to the main /etc crons, but i think crons runs per user sandboxed on my server ..  hmm.. ponder ponder.. so many variables.. 


                                                              💓0 😆0 😲0 😥0 😠0 0
                                                              • Hi......

                                                                Has this been resolver. I also have the problem......it stay stuck on  ""Scheduled for publishing as soon as video conversion is complete."" 

                                                                I have been at it for 5 days now...…..

                                                                I need this to work...…. The website is for a church community and we are in lockdown the pastor want to send his messing out on video

                                                                Regards



                                                                💓0 😆0 😲0 😥0 😠0 0
                                                                • I'm still working it out..  About to do another test.   What kind of system are you running your una on?  I may or may not be able to help, but I'll do my best to point you at least a bit further hopefully than you are now.  :)

                                                                  💓0 😆0 😲0 😥0 😠0 0
                                                                  • Hi 

                                                                    I am running Linux and a shared server …..

                                                                    All my other uploads work photo's, files and audio……..only video does not work

                                                                    Regards

                                                                    💓0 😆0 😲0 😥0 😠0 0
                                                                    • Hi Louwrens,

                                                                      My latest tests have still to be successful...


                                                                      Once I figure out more I hope that I can help you.

                                                                      💓0 😆0 😲0 😥0 😠0 0
                                                                      • ha, Chris  is "undefined" in grey the same as "failed" ? i know i have mod_rewrite, and its definitely something other websites of mine have used before una..  


                                                                        i assumed grey was a soft error like the una script couldnt determine the parameters but detected it was there.. 


                                                                        otherwise there are no "fail" in red,,  theres no php accelleration right now ,  and using file cache because its an ssd, but eventually i may configure memcached but one thing at a time... and by configure i mean via systemctl, etc...  not just "plugging it in"  that would not work.


                                                                        re mod rewrite see image: also running the suggested command as su yields a blank newline with zero output.

                                                                        image_transcoder.php?o=bx_froala_image&h=3428&dpx=2&t=1587294137

                                                                        💓0 😆0 😲0 😥0 😠0 0
                                                                        • this has been solved, Louwrens Vorster do you still need help?  How about you James Zandreiatti  ?

                                                                          💓0 😆0 😲0 😥0 😠0 0
                                                                          • I am having the same issue.  What was the solution?

                                                                            💓0 😆0 😲0 😥0 😠0 0
                                                                            • I have the same problem, did you find a solution?

                                                                              💓0 😆0 😲0 😥0 😠0 0
                                                                              • I did.  I stopped trying to fix una, and just stopped using it.  Clearly this isnt a solution if you're emotionally invested, and i do still have an una site- i just refuse to work on it or spend any time updating it.   sure bro, its a lovely house-  but nobody lives in it, so it doesnt matter worth a damn, until the technology is used in the manner im hoping it was originally designed for


                                                                                to produce a modular system that can be adapted to anywhere on the web and live through time.

                                                                                i think.

                                                                                this is not going to work unless una is constantly developed- because its developed with technologies that are constantly changing


                                                                                so the headache of that entropy will come along with trying to use a system like una, until it is fully matured- and standardized, (if that ever can even happen) because we hvae been trying with the web for 30 years or so but not a lot yet in that dept outside of protocols, and stuff. but that works because they have engineering teams designing them and they dont take much input.

                                                                                so- while i did find a solution, i literally have no idea what the problem originally was, i cannot remember, and i tried, hit a blank in my head, dont care, functionally- because eh, its just not worth it.

                                                                                theres no reason to use this unless your a programmer and want to fix it, or dont understand icons and are drawn in by how nice unas icons look and assume its going to be easy- well that is not a strategy for creating a secondary support market, but i am also not suggesting this either. software is complicated. :) but i fear una has a unusually high number of normal people here trying to run software- and this is a headache that if una anticipated they arent handling quite very well ,because una academy has no structure-. its there, but there are no teachers. and i get self directed is the idea, but most people cant even take apart a toaster and put it back together-

                                                                                so lets be honest what are we doing here?

                                                                                hope you are all in good spirits and healthy and enjoying you lives.

                                                                                take care :D and hope to hear of your success.


                                                                                💓0 😆0 😲0 😥0 😠0 0
                                                                                Not logged in users can't 'Comments Post'.
                                                                                19
                                                                                1
                                                                                2
                                                                                2
                                                                                4
                                                                                Labels:
                                                                                Added:
                                                                                Category:

                                                                                UNA - Network Infrastructure for Communities

                                                                                Close