•  · 12 friends

Problem with email notifications

Hello LeonidS Alex T⚜️ Andrew Boon

Do you have any idea why this could happen?

Some types of notifications are not sent.

I am testing with a personal profile that has all notifications enabled.

In 2 web pages the exact same thing happens to me. They both use SMTP Mailer. One is configured with Mailjet, the other with the VPS hosting mail server (TMD).

On the page that is configured with Mailjet I can see the details of the shipments made.

These notifications are not sent: reply to a comment in a discussion, mentions (@), contact requests, likes.

These notifications work correctly: email confirmation request, new response to a discussion (it only reaches the person who posted the discussion), messages between users (conversation), new password, password reset, profile activated.

I do not know if it has any relationship, for the doubts I mention that for a long time I have not received the report of how many accounts were created on the day.

Thank you very much.

Regards.

💓0 😆0 😲0 😥0 😠0 0
  • 679
  • More
Replies (18)
    • I'm having similar issues, I think the problem with notifications it's widespread.

      In my case, emails are not sent when someone sends a Messenger to another member. Email confirmation request works well though.  

      💓0 😆0 😲0 😥0 😠0 0
      • Hi caldopollo 

        I remember that when I launched my page, 3 months ago, it was version 10 of UNA, I had tried and all the notifications worked. Then when updating to the new versions, I did not try again, just now I did it again. I am concerned that notifications serve to mobilize exchange on the network.

        I do not have Messenger, therefore I cannot comment on it. Like you, email confirmation requests work fine.

        💓0 😆0 😲0 😥0 😠0 0
        • The notifications module has errors for us too. Some mails are sent some are not. Duplicate mails are sent to some users. We have disabled all email notifications in settings, mail is still getting sent.

          💓0 😆0 😲0 😥0 😠0 0
          • Hello LeonidS Alex T⚜️ Andrew Boon could you see this topic please? Thanks.

            💓0 😆0 😲0 😥0 😠0 0
            • Hello LeonidS Alex T⚜️ Andrew Boon Mark Purser

              Excuse for the insistence. Even though you can't answer right now, it would be nice to know if at any time someone from the UNA team will see such an important topic like this. Thanks.

              💓0 😆0 😲0 😥0 😠0 0
              • Alexey 

                Could you help me with this?

                Thanks.

                💓0 😆0 😲0 😥0 😠0 0
                • Hello LeonidS Alex T⚜️ Andrew Boon Alexey

                  I am quite frustrated at the lack of response. The truth that I do not understand, because I see that you respond to other problems, but not this one.

                  Regards.

                  .

                  💓0 😆0 😲0 😥0 😠0 0
                  • Sorry for delay

                    Please check the following things:

                    - if all necessary notifications are enabled in Studio and in User side in your profile: Studio > Notifications & Account > Settings > Notifications

                    - sometimes in Studio you can see exclamation mark near some type of notifications, then you need disable it and enable again
                    - check if you are subscribed to notifications: Account > Settings > Email

                    - check if your email is unsubscribed or blacklisted in your SMTP service

                    💓0 😆0 😲0 😥0 😠0 0
                    • Hello Alex T⚜️ 

                      Thanks for your answer.

                      I did the indicated checks:

                      - All notifications are active in Studio> Notifications (On site, Email, Push).

                      - On the user side, all notifications are also activated.

                      "sometimes in Studio you can see exclamation mark near some type of notifications, then you need disable it and enable again"
                      - I don't understand what you mean. Anyway I did not find any exclamation point in any notification.

                      - Email subscription notification is also enabled.

                      "check if your email is unsubscribed or blacklisted in your SMTP service"
                      - Where do I have to see this?

                      Thanks.

                      💓0 😆0 😲0 😥0 😠0 0
                      • "sometimes in Studio you can see exclamation mark near some type of notifications, then you need disable it and enable again"
                        - I don't understand what you mean. Anyway I did not find any exclamation point in any notification.

                        It's in Studio > Notifications and looks like this:

                        "check if your email is unsubscribed or blacklisted in your SMTP service"
                        - Where do I have to see this?

                        All SMTP services are different? so I can point you in some particular place, you can see activity log maybe it will shed some light on why emails aren't sending also it should somewhere block lists and unsubscribed users too.


                        💓0 😆0 😲0 😥0 😠0 0
                        • Hello Alex T⚜️

                          I confirm that the exclamation symbols do not appear.

                          As for the SMTP service, I use Mailjet for one web page and for another web page I use the one provided by TMD Hosting through the VPS hosting that I have contracted.

                          LeonidS asked me for access data to cPanel, UNA Studio, etc. I just sent them to him. I suppose he will want to see this that you indicate.

                          Thanks.

                          💓0 😆0 😲0 😥0 😠0 0
                          • Hi Alex T⚜️ 

                            Leonid was investigating and found that the cron jobs were not working. Now they work, however the problem with some notifications continues.

                            Regards.

                            💓0 😆0 😲0 😥0 😠0 0
                            • Leonid was investigating and found that the cron jobs were not working. Now they work, however the problem with some notifications continues.

                              If your cron jobs wasn't working for a long time, it maybe you have long queue of emails and/or notifications, please try to clear these queues so new notifications will be sent straight away, to do it clear the following tables: sys_queue_email, sys_queue_push, bx_notifications_queue

                              💓0 😆0 😲0 😥0 😠0 0
                              • These problems are common on notification. 

                                we had to get a third party to write code to strip out duplicates that the system put into the queues.

                                you can clear those folders and inspect the tables, they will look clean and then the system will misfire and send out so many spam mails.

                                This is a UNA problem without solution

                                💓0 😆0 😲0 😥0 😠0 0
                                • Hello Alex T⚜️ 

                                  In www.trabajoenelnea.com.ar and in www.tnoa.com.ar the indicated tables were empty.

                                  At www.tnoa.com.ar I was using Mailjet (free plan) and today I had reached the limit of 200 daily notifications, therefore no new notifications were being sent.

                                  What I did in this case (www.tnoa.com.ar) was to change the SMTP Mailer settings, I removed Mailjet and configured my VPS hosting server in TMD. Then the notifications started coming. I was checking for a few hours and all notifications are being sent.

                                  What confuses me is that SMTP Mailer is configured the same way at www.trabajoenelnea.com.ar, however I still have the same problems, with mention notifications, contact requests, etc.

                                  I can't think what the difference may be.

                                  Regards.

                                  💓0 😆0 😲0 😥0 😠0 0
                                  • Hello Alex T⚜️

                                    I do not know if it has to do, but I deactivated the Notifications app, I activated it again and the notifications that did not work, now they work.

                                    It can be that?

                                    💓0 😆0 😲0 😥0 😠0 0
                                    • I do not know if it has to do, but I deactivated the Notifications app, I activated it again and the notifications that did not work, now they work.

                                      It can be that?

                                      It could happen if you have some notification deactivated on admin side or on user side, also it maybe that some notifications are out of sync (exclamation mark). Also it maybe some events aren't properly registered, so enabling/disabling Notifications module could help in this case.

                                      💓0 😆0 😲0 😥0 😠0 0
                                      • These problems are common on notification. 

                                        we had to get a third party to write code to strip out duplicates that the system put into the queues.

                                        you can clear those folders and inspect the tables, they will look clean and then the system will misfire and send out so many spam mails.

                                        This is a UNA problem without solution

                                        It's better to report what exactly is happening and describe the way how to reproduce it, so we'll be able to investigate and fix it.

                                        💓0 😆0 😲0 😥0 😠0 0
                                        Not logged in users can't 'Comments Post'.
                                        11
                                        5
                                        1
                                        2
                                        Labels:
                                        Added:
                                        Category:

                                        UNA - Network Infrastructure for Communities

                                        Close