Group Badges

Has anyone noticed how badges are not working on groups. I have a number of UNA installs and its the same on all of them. Bug possibly?

Update 2/11/2020: 

I have found that Group Badges will not show unless Events is installed and a Badge has been added to Events.

If you disable Events or Delete all Badges from Events this hides Set Badge again in Groups. 

This Must be a bug, also I notice that Badges for Events & Groups share the same onclick entry "bx_menu_popup('sys_set_badges', window, {}, {module: 'bx_groups', content_id: {content_id}}); " I am sure events should be like this "bx_menu_popup('sys_set_badges', window, {}, {module: 'bx_events', content_id: {content_id}}); "

And set_name entry for Events Module is using the same set_name for Groups Module "bx_groups_view_actions_all " , where i am sure the set_name for Events should not be using Group set_name. And I don't know why Events is using the "view_actions_all " and there is no entry for Events that should be "bx_events_view_actions".

I have uploaded the SQL entries for the two menu items that seem to be conflicted.

This is on all my UNA installs.

I think Event's and Group's Set Badge menu link is conflicting and using Event's Badges to confirm that there is badges before the Set Badge button is available in Groups.

2nd Update 2/11/2020:

It's now being investigated by UNA.


0 0 0 0 0 0
  • 170
Attachments
Replies (7)
  • Hello merseytechhub !

    May you please specify more details about what and how doesn't work? 

    0 0 0 0 0 0
    • Well Badges in Discussions, Persons, and Organizations are working and I can see the Set Badge Button. But in groups there is no button to setup badges.

      I have tested this on over 3 different installs and its the same on all of them.  

      0 0 0 0 0 0
      • Please specify the parameters of your badge variant which doesn't work fine in Groups and works fine in other apps. From my side, the simple colorized badge works fine in Groups and Discussions.

        0 0 0 0 0 0
        • I have tried simple colorized and ones with icons ones without. I have tried single and multiword. 

          It's just the option to set a bad to groups are not there and I don't understand why it's the same for all my installs of una.

          I have also checked the navigation in admin panel and the menu item is there for badges and permissions are set to admin and mod.

          I have attached 3 photos, one showing on both menus Set Badges option is not there. Then one showing the different variants. I have also tried each of these on their own and still the Set Badge option is not there. I do not have this problem on any other module and I have it on all 7 of my UNA install. And one showing the option on the Group Menu.

          I have checked the OnClick data and its the same on all of my UNA installs. I have also looked into all MySQL entries on each UNA install for Badges for groups and they are the same on all UNA Sites I have.

          I have also tested a brand new install and same problem. 

          0 0 0 0 0 0
          • I have updated this discussion with information about my own investigation.

            0 0 0 0 0 0
            • This is now being investigated by UNA.

              0 0 0 0 0 0
              • UPDATE - it seems the fix was a part of another solved challenge, so this issue exists in 11.0.3 but already fixed in the closest release but without the separate ticket.

                0 0 0 0 0 0
                Not logged in users can't 'Comments Post'.
                5
                3
                Labels:
                Added:
                Category:

                UNA - Social Media Software Framework

                Close