•  · 9 friends

Contact Module not installing on UNA 12.1.0

Hello everyone,

Has anyone had any issues installing the Contact Module on UNA 12.1.0 self hosted? I wanted to create an email form for users to contact us and I came across this module. When I try to install it, I get the error in the screenshot. 

I assume that this module is supported so I tried to remove it, clear the server caches, etc and nothing helps.

💓0 😆0 😲0 😥0 😠0 0
  • 194
  • More
Attachments
Replies (5)
    • Hello Stephen Bakerman !

      Looks like you had already this module installed and it was not properly deleted. Try to delete it again and install one more time.

      💓0 😆0 😲0 😥0 😠0 0
      • I should have mentioned that I tried that a few times yesterday afternoon without success. I will try again right now though and see if it works and let you know. Thanks


        💓0 😆0 😲0 😥0 😠0 0
        • This was a new UNA install and I never installed the Contact Module before.

          💓0 😆0 😲0 😥0 😠0 0
          • I fixed the problem and it had nothing to do with the module being previously installed, we created a custom page called "Contact" and this page entry in the table "sys_objects_page" was using the same URI that the Contact Module was trying to use which is "contact".

            I deleted the custom page we created called "contact" and installed the Module successfully. 

            Why do the modules install pages in the same table as custom pages and would it not be better to keep them in separate tables?

            💓0 😆0 😲0 😥0 😠0 0
            • But it is much simpler to have similar things (pages) in one place. And takes fewer resources.

              💓0 😆0 😲0 😥0 😠0 0
              Not logged in users can't 'Comments Post'.
              4
              2
              Added:
              Category:

              UNA - Network Infrastructure for Communities

              Close