• 98
  • More

Problem with update from 11.0.1 to latest 12.1

Hello,

I don't have customizations and I've just updated from 11.0.1 to 12.1 via Studio.


Looks that there is a few urgent problems I cannot solve, site is not 100% functional :

1- the Timeline app cannot update from 11.0.7 to 12.0.0, I get error messages "Changing database : There are errors in the following Mysql queries : Error illegal mix of collations (utf8mb4_general_ci.implicit AND (utf8mb4_unicode_ci,IMPLICIT) for operation '='

DELETE FROM 'sys_pages_conte


2- When connected I cannot access to organization's page anymore, I get a blank page. When I go to the same page as non member (= not connected) I can see the page.

edit : looks that I get an http 500 error when certain type of profils (administrators for example) try to see own or others organization's profils

"This page isn’t working

maintenancia com is currently unable to handle this request.HTTP ERROR 500"


I've noticed that this error occurs depending on the profil you are connected with. Looks it is affecting admin level profils. Why ??

For example :

  • UNA site main administrator cannot see any org pofile -> blank page
  • an organization that has an "admin" profil


I cannot solve this issue...

Could you please help ?

Thank you

💓 0 😆 0 😲 0 😥 0 😠 0 0
Replies (5)
    • Hello @Miroslav !


      About first point you may apply the solutions fro this thread https://una.io/page/view-discussion?id=7795


      About second - you need to check your error log files in your UNA's server and provide the latest fatal errors from there.

      • Hello Leonids,


        I have checked log files and noticed that the second issue is caused by the timeline app. Most probably because upgrade was not completed due to the SQL error.

        just for reference :

        [Wed Apr 06 20:46:39.155333 2022] [proxy_fcgi:error] [pid 734302:tid 140087709521664] [client 141.101.68.26:64220] AH01071: Got error 'PHP message: PHP Warning:  require_once(/srv / www . myunasite. com / una / modules / boonex / timeline / classes / BxTimelineUploaderRecordVideoAttach . php): failed to open stream: No such file or directory in / srv / www . myunasite . com / una / inc / classes / BxDolUploader . php on line 149PHP message: PHP Fatal error:  require_once(): Failed opening required ' / srv / www . myunasite . com / una / modules / boonex / timeline / classes / BxTimelineUploaderRecordVideoAttach . php' (include_path='.: / usr / share / php ') in / srv / www . myunasite . com / una / inc / classes / BxDolUploader . php on line 149', referer: https : // myunasite . com /
        

        After (temporarely and for the sake of checking the above hypothesis) disabling the permission to publish things on the timeline, every profile type is able to access the profile pages.


        I now need to solve the sql issue by doing what has been suggested in the thread you've mentioned :

        Then you may try to change the collation of your UNA tables from utf8mb4_general_ci to 
        utf8mb4_unicode_ci and try to update modules again.

        and then be able to resume upgrading the timeline app from 11.0.7 - 12.0.0 and on.


        for reference, the error while trying to upgrade the timeline module from 11.0.7 - 12.0.0 is :

        Operation failed:
        Timeline : Changing database: There are errors in the following MySQL queries:<br />Error: Illegal mix of collations (utf8mb4_general_ci,IMPLICIT) and (utf8mb4_unicode_ci,IMPLICIT) for operation '='
        <pre>DELETE FROM `sys_pages_content_placeholders` WHERE `module`=@sName AND `title`='_bx_timeline_page_content_ph_timeline';pre>
        
        • For the second point you need to fix this part in your server

          include_path='.: / usr / share / php '
          


          About your unicode collation trouble, you need to apply the query to transfer the all non-transferred tables  from utf8mb4_general_ci to 

          utf8mb4_unicode_ci and try to update modules again.

          • 1) Question : I see about 60 tables with utf8mb4_general_ci do ALL tables need to be transferred from utf8mb4_general_ci to utf8mb4_unicode_ci ?

            bx_* tables and sys_* tables


            2) I also see tables with utf8_general_ci (like bx_ads_* ) should I also change these ?


            3) some tables have columns with utf8mb4_general_ci , I suppose it also should be changed to utf8mb4_unicode_ci ? for example table bx_albums_cmts_notes , the column cm_text

            • OK, I've changed all tables and columns from utf8mb4_general_ci to utf8mb4_unicode_ci

              and the update process of the timeline module worked fine (I've also had the studio access issue and solved it as described in the ticket you've mentioned).

              All modules are now up to date for my 12.1 UNA site. Ready for the next one ;-)

              Not logged in users can't 'Comments Post'.
              Miroslav
              • 61 views
              4
              2