Kyle

  •  ·  Premium
  • 3 members
  • J

    19 followers
  • 2054 views
  • 2 votes
  • More

I am horrible at updating this stuff 😜 My name is Kyle. I am originally from NY and now in Texas in the U.S. I have a passion for web development and I continue to learn. Una has allowed a back end to save me time with my busy life. I used Dolphin awhile back and was not as impressed as I am with Una. I also love gaming and music. I run an talent/hobby sharing community called Myvybz.com (formerly vybz.live) using UNA and an upcoming company called VyBZ.XYZ Media and Design (web design and sound editing). Due to royalty costs, etc, I had to let radio.vybz.live go, but still dj online and virtual worlds. 

Add new...
 
 
·
Added a discussion

Below is what I am seeing a lot in relation to errors from my site error logs. I wanted to report this. I see others have mentioned video issues as well. Same issue still present on 13 B1. **Update 5/28/22: With some time to dig, The video poster error is literally what the issue is, it is the video posters. When you upload a video poster for the video it does not show, it will if your put it in the post itself though. Wonder if it is something to do with storage possibly. Unsure, but definitely not showing uploaded poster images. It does upload (Proof: https://myvybz.com/s/bx_videos_photos/tgtyfr4bekqjwvcknpw2uduf2gcg7jkw.jpg) just it does not show as poster when selected**

 $aTmplVarsVideos[] = array(
                        'style_prefix' => $sStylePrefix,
                        'class' => '',
                        'item' => $this->parseHtmlByContent($sAttachTmpl, array(
                            'style_prefix' => $sStylePrefix,
                            'bx_if:show_link' => array(
                                'condition' => $bUrl,
                                'content' => array(
                                    'style_prefix' => $sStylePrefix,
                                    'url' => $sUrl,
                                    'src' => $aVideo['src_poster'],
                                )
                            ),
                            'bx_if:show_non_link' => array(
                                'condition' => !$bUrl,
                                'content' => array(
                                    'style_prefix' => $sStylePrefix,                                    'src' => $aVideo['src_poster'],                                )                            ), 


Here are three different users same error 1 minute after the other:


39817#0: *12928 FastCGI sent in stderr: "PHP message: PHP Warning: Undefined array key "src_poster" in /var/www/vhosts/-----/httpdocs/modules/boonex/timeline/classes/BxTimelineTemplate.php on line 2772PHP message: PHP Warning: Undefined array key "src_poster" in /var/www/vhosts/-----/httpdocs/modules/boonex/timeline/classes/BxTimelineTemplate.php on line 2779" while reading response header from upstream
  • 109
·
Added a discussion

** I found the issue, the minute I swapped back to 7.4 from ages ago, no issue with Developer. Are not all modules with UNA 8.0 compatible? I was using PHP 8.0.19. I thought everything was made compatible with PHP 8? Sadly it did not fix my Artificer formatting issues though, but it atleast fixed Developer module. I did a clean load of UNA about a year ago and was on 7.4 until Msolutions got his modules changed over to 8.0 then I made the switch. For now if I need to do anything in developer module will change back to 7.4 and change back :D. **

***Could be to 8.1 compatibility even though I am still on 8.0 using the last version of 8.0 before 8.1. This is on Github as issue to be fixed in regards to 8.1 compatibility for Developer in 13 B2.***


I noticed my developer module is not working for awhile now. When I go to save for any settings, the loading symbol just keeps spinning and nothing ever saves. In my logs I get the following:


500POST /studio/options.php?type=system HTTP/2.0




418868#0: *104571 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Unknown named parameter $min in /var/www/vhosts/-----/httpdocs/studio/classes/BxDolStudioOptions.php:300

Stack trace:

#0 /var/www/vhosts/-----/httpdocs/studio/template/scripts/BxBaseStudioOptions.php(151): BxDolStudioOptions->saveChanges()

#1 /var/www/vhosts/-----/httpdocs/studio/options.php(32): BxBaseStudioOptions->getCode()

#2 {main}

thrown in /var/www/vhosts/-----/httpdocs/studio/classes/BxDolStudioOptions.php on line 300" while reading response header from upstream


Anyone else run into this at all? Did not recognie it until I went to change a setting and save in there today. Everything in there looks as it should. I have tried uninstalling the right way through studio and then reinstalling and same thing.



  • 117
    Not logged in users can't 'Comments Post'.
    ·
    Added a discussion

    I am trying to figure out why my Macros keep showing malformed when I try them. Is there something I am supposed to be removing from the main code I am using. I have been trying to read here: UNA: Service Calls I want to show all posts from my community organization profile or a whole post would be good to so I can show whole post on one update screen. Is there anyway to do that? I am tryign to get the hang of these things. The one below will ofcourse give the malformed error. Quick note: I am using the HTML block, tried on all of them. Moved to Alpha Beta RC as this has been reported.

    image_transcoder.php?o=sys_images_editor&h=366&dpx=1&t=1652977954

    Error: malformed macros

    bx_posts:browse[{"mode":"author", "params":{"author":"1"}}]  deleted the beginning and end curly brackets so I could put it here.  
    
    • 136
      Not logged in users can't 'Comments Post'.
      ·
      Added a discussion

      Test not wrapping on profile. Fine in Lucid, not in Artificer. I use custom blocks to add additional information on profiles and other context areas in the main info block. The text is not wrapping, not sure if it is known, wanted to report it. Also when editing a page and you add a html block any that use the editor it will not notice code and will not follow formatting. For now I am using the Raw block which works as an alternative for now. 5/21/22 update: We will see if this fixes in the Beta. What I can say is I removed Artificer the right way completely, reinstalled it and still the same thing. Everything else it beautiful except for no scrolling in popup windows like relationships for example :D This has been fixed in UNA 13 B1.

      image_transcoder.php?o=sys_images_editor&h=358&dpx=1&t=1652641400

      • 122
        • Hello @Kyle !


          Plz specify your actions. Did you add the text field with editor to the "Create profile" form and then insert it to the "View info" block? If so then I have tested the fields by this way too and HTML formatting works fine. Possibly, I may suggest that the column width isn't enough to apply all styles parts.

          • It was fine with Froala, if I write a sentence it will just keep going and never wrap text. Embed and stuff work fine I have discord embedded one profile and sound cloud on another profile so it is definitely not that. they show fine, just for some reason text is not wrapping it just continues on without wrapping. These are text areas. I changed back to LUCID and the text is wrapping, just not in Artificer

            Not logged in users can't 'Comments Post'.
            ·
            Added a discussion

            B1 Further update: Errors are still there. The Charts ones are gone, but the ones when going to peoples profiles with SEO links on are still there and can be seen below.

            I was wrong the errors came back while I was sleeping last night. So the main thing found when using SEO links alone or with SEO link redirects the urls showing, are not the ones that are actually pulling and showing on the website are fine, but the database error is showing the link with a number at end like if you were to create a new profile example with the same name it adds a number to end. This is with all context areas and profile types.

            B1 Update: I will watch these like a hawk, not really I will check in morning and see if they return overnight. Other then that no issues so far since update and usually have at least one by the afternoon.

            B1 Further update: Errors are still there. The Charts ones are gone, but the ones when going to peoples profiles with SEO links on are still there and can be seen below.



            Just wanted to mention some database errors I have been getting with UNA 13 A3, they may be known, this is also after trying to change version back to A2 and re-upgrading. I was being flooded with the,m, but after the re upgrade they slowed down to maybe 6 a day instead of 100 :D. This is also with all modules, especially Msolutions disabled. I disabled them all before re-upgrading to be on safe side. This is just for bug reporting purposes for most part. This is same with two UNA installations being I host someone who is having the same errors, his being freshly installed since UNA 13 A2. Alot of these areas duplicate when you go into events ofcourse and groups. I see you have one on charts and events in Github reports and a good chance the other context areas may be the same thing.


            Query:
            SELECT COUNT(*) FROM `sys_profiles` AS `p` INNER JOIN `sys_accounts` AS `a` ON (`a`.`id` = `p`.`account_id`) {join_connections} WHERE 1
            Mysql error:
            You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '{join_connections} WHERE 1' at line 1
            collation_connection:
            utf8mb4_unicode_ci
            
            ----
            Called script:
            /page.php
            
            Request parameters:
            
            
            array (
              'i' => 'persons-profile-friends',
              'id' => '4',
            )
            
            
            


            Query:
            INSERT INTO `bx_charts_most_active_profiles` (`object_id`, `profile_module`, `content_module`, `create_count`) SELECT `sys_profiles`.`content_id`, `sys_profiles`.`type`, 'bx_timeline' , COUNT(`bx_timeline_events`.`id`) FROM `bx_timeline_events` INNER JOIN `sys_profiles` ON `sys_profiles`.`id` = `bx_timeline_events`.`object_owner_id` WHERE sys_profiles.type='bx_organizations' AND `bx_timeline_events`.`added` > 1651107604 GROUP BY `sys_profiles`.`content_id`, `sys_profiles`.`type` ORDER BY COUNT(`bx_timeline_events`.`id`) DESC LIMIT 0,4
            
            Mysql error:
            Unknown column 'bx_timeline_events.added' in 'where clause'
            
            collation_connection:
            utf8mb4_unicode_ci
            
            ---
            
            Called script:
            /var/www/vhosts/---/httpdocs/periodic/cron.php
            
            
            


            Query:
            SELECT COUNT(*) FROM `sys_profiles` AS `p` INNER JOIN `sys_accounts` AS `a` ON (`a`.`id` = `p`.`account_id`) {join_connections} WHERE 1
            
            Mysql error:
            You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '{join_connections} WHERE 1' at line 1
            
            collation_connection:
            utf8mb4_unicode_ci
            
            Debug backtrace:
            
            ---
            
            Called script:
            /page.php
            
            Request parameters:
            
            
            array (
              'i' => 'organization-profile-friends',
              'id' => '3',
            )
            


            Some more since I sent this:


            Query:
            SELECT COUNT(*) FROM `sys_profiles` AS `p` INNER JOIN `sys_accounts` AS `a` ON (`a`.`id` = `p`.`account_id`) {join_connections} WHERE 1
            
            Mysql error:
            You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '{join_connections} WHERE 1' at line 1
            
            collation_connection:
            utf8mb4_unicode_ci
            
            ---
            Called script:
            /page.php
            
            Request parameters:
            
            
            array (
              'i' => 'persons-profile-friends',
              'id' => '3',
            )
            


            Query:
            SELECT COUNT(*) FROM `sys_profiles` AS `p` INNER JOIN `sys_accounts` AS `a` ON (`a`.`id` = `p`.`account_id`) {join_connections} WHERE 1
            
            Mysql error:
            You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '{join_connections} WHERE 1' at line 1
            
            collation_connection:
            utf8mb4_unicode_ci
            
            ---
            Called script:
            /page.php
            
            Request parameters:
            
            
            array (
              'i' => 'organization-profile-fans',
              'id' => '1',
            )
            
            


            Query:
            SELECT COUNT(*) FROM `sys_profiles` AS `p` INNER JOIN `sys_accounts` AS `a` ON (`a`.`id` = `p`.`account_id`) {join_connections} WHERE 1
            
            Mysql error:
            You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '{join_connections} WHERE 1' at line 1
            
            collation_connection:
            utf8mb4_unicode_ci
            
            ---
            
            Called script:
            /page.php
            
            Request parameters:
            
            
            array (
              'i' => 'organization-profile-friends',
              'id' => '1',
            )
            
            
            
            


            • 331
              Not logged in users can't 'Comments Post'.
              Kyle Discussions
              • Kyle
              • Replies (5)
              • Unresolved
              • Kyle
              • Replies (2)
              • Unresolved
              • Kyle
              • Replies (2)
              • Resolved
              • Kyle
              • Replies (6)
              • Unresolved
              Achievements

              Grand Master

              Total points: 2421

              5779.2 point(s) to reach
              Info
              Organization Name:
              Kyle
              Category:
              Friends count:
              Followers count:
              Membership
              Premium