•  · 25 friends

video post error

Hello

when I add a post with video I got this error and the post does not show on the timeline

Best

Andrew Boon Alex T⚜️ Anton L Alexey LeonidS Mark P 

image_transcoder.php?o=bx_froala_image&h=3109&dpx=1&t=1584357660

0 0 0 0 0 0
  • 188
Replies (12)
  • Please specify your UNA version, also check if your ffmpeg binary is for correct platform, by default we use ffmpeg for Linux and check if ffmpeg permissions are correct in Studio > Dashboard > Host Tools > Permissions

    0 0 0 0 0 0
    • una version : 11.0.0-B1 and 11.0.0-RC1 both give same error 

      Permissions : 

      Path Current status Desired status
      cache Writable Writable
      cache_public Writable Writable
      logs Writable Writable
      tmp Writable Writable
      storage Writable Writable
      plugins/ffmpeg/ffmpeg.exe Executable Executable
      0 0 0 0 0 0
      • I checked the log in the table sys_transcoder_queue :

        store local tmp file failed (storeFileLocally_Storage)

        the folder public_html/tmp has permission 0777

        Alex T⚜️ 

        0 0 0 0 0 0
        • Did you ever set storage engine to S3 instead of Local ? Does your server have enough free space ?

          0 0 0 0 0 0
          • the storage is set to local and i have free space

            0 0 0 0 0 0
            • Please check if "Remote Transcoding" option is disabled in Studio > Developer > Settings

              0 0 0 0 0 0
              • it is disabledimage_transcoder.php?o=bx_froala_image&h=3163&dpx=1&t=1585105961

                0 0 0 0 0 0
                • I have the same issue.   Was a solution ever discovered?  Every request has "local tmp file failed (storeFileLocally_Storage)"   The server has 900GB free and I checked the settings as indicated above.

                  0 0 0 0 0 0
                  • I may have found the actual problem.

                    In the /storage/ directory there are a number of bx_... directories.   All of them were owned by www-data except bx_timeline_videos_processed which was owned by root.   I did a  chown -R www-data:www-data bx_timeline_videos_processed and now posts from yesterday are showing up with working video's.

                    I have to check with other users to see if their videos are now working as well.

                    Keep your fingers crossed.

                    0 0 0 0 0 0
                    • make that chgrp -R ...

                      0 0 0 0 0 0
                      • very interesting.. i see all my videos in the storage directories and however i dont even have a transcoder error log, but am a bit stuck on my setup.  this was one of the only threads i had not read fully yet and checked off step by step..

                        0 0 0 0 0 0
                        • all folders are owned by httpd/unix-directory so this is not the problem and all are 755

                          0 0 0 0 0 0
                          Not logged in users can't 'Comments Post'.
                          Labels:
                          Added:
                          Category:

                          UNA - Social Media Software Framework

                          Close