•  · 3 members
  •  · 11 friends

*Need Help* Timeline Upload Items not working - "Missing Marka.JS.Map"

So after days and weeks and no advice helping I found the cure. I am on MariaDB and change to Aria for my engine instead and it fixed the issue! 😖 


😔 Dealing with issues when I upload more then 1 image on timeline. I will upload 5 images for example. They will show up blank with delete underneath. I will then refresh page and they will show and then go to hit post and refresh page again and its posted. *Update* This happens on all plugins where uploads are happening. Definitely pointing to a Jquery problem I think 😵 

image_transcoder.php?o=bx_froala_image&h=2822&dpx=1&t=1579899701

They do process after the refreshing 😩, so it is very strange 😳  and looks like keep alive wasn't the issue so turned it back on. They basically get stuck on the loading. Whenever this happens it affects all users on the website and will put their timelines in a never ending loop. Until I either delete the post or do the double refresh one to get them to load and again for the post. Bad thing is the only errors I am getting for litespeed is that marka js error. Nothing closing or timing out. Makes this ten times harder to troubleshoot- Source map error: Error: request failed with status 404 Resource URL: https://vybz.live/gzip_loader.php?file=bx_templ_js_12f25d14d5df616bca981c9f8184c807.js Source Map URL: marka.min.js.map; 

I have always had trouble with the uploading of images before migration. Uploading an album of 10-20 pictures takes longer to process then a 10 minute video. It is crazy. My specs are really high and PHP.INI settings are set to higher numbers just in case. Since migration this has become an additional problem and already have uninstalled and reinstalled the Timeline module.  Anyone else dealing with this or have any ideas I have not thought of or tried?

image_transcoder.php?o=bx_froala_image&h=2821&dpx=1&t=1579894837

 

image_transcoder.php?o=bx_froala_image&h=2823&dpx=2&t=1579917759

image_transcoder.php?o=bx_froala_image&h=2824&dpx=2&t=1579917867

image_transcoder.php?o=bx_froala_image&h=2825&dpx=2&t=1579917933

Quick update only happens on multiple images to the timeline post, even when it is two. If just one, not an issue. The multiple image upload would need Jquery to run without needing refresh, so far I am really thinking its relating to the missing marka.min.js.map if I had to guess right. Another update, happening anywhere including Albums. I just noticed something weird, it was there before, my GD Library enable checkbox is missing from settings. It was in developer mode. So I have tried multiple times for the heck of it even with GD library disabled being I have image magick to and still in litespeed I see that missing marka.js. 

image_transcoder.php?o=bx_froala_image&h=2829&dpx=1&t=1580033527

Found it, it is in plugins_public folder.

image_transcoder.php?o=bx_froala_image&h=2827&dpx=2&t=1579943872



[807504] [Someones IP😱 :HTTP2-113] File not found [/homedirectory/domain/public_html/marka.min.js.map;]

 Should something be directing it to the java folder in Public Plugins. I do see anything in the image transcoder or handler file. LeonidS  Andrew Boon  Anton L Do you happen to know what file is calling to the marka.min.js file? Or anyone ofcourse. I remember after migration I had to update the Header Inc and I asked if I had to edit any other files and never got an answer. Guess I will ask again :P Are there any other files that would need to be changed if a directory changed upon migration?  For example in Cyberpanel from CPANEL it changes from name to domain. Again all liens in Header Inc have been updates so any other files but that one 😬 

See Alex's last response: marka.js.map error isn't related, you can safely ignore this error, .map file is loaded only when browser debug panel is open for more easy debug.I suspect that it maybe be deadlock in the DB, are you using InnoDB by any chance ? if yes, then server need to be properly configured for InnoDB, in other case use MyISAM or its derivatives.  

Sooo.... it looks like my issue was database related, thank you Alex T⚜️ for the push to retry some options I deleted earlier when my database would not restart due to unreadable commands. Looks like some things are different with InnoDB in Maria. For example this one innodb_rollback_on_timeout=on and this line does not exist: binlog_format = MIXED so these were what was throwing off my My.CNF when I deleted the other options. I didnt have to change my pool_instances because mine is on 8 by default.   Please still do share if I should remove any of these. I will update with my full InnoDB stats once I get feedback on my current settings. 

Scratch that *sighs* still no fix. It may be some of my extra options I am using.  This issue not resolved. 

0 0 0 1 0 0
  • 226
Replies (29)
  • Kyle this seems like a setting problem of your server.

    İt may be a permission problem or something like that.

    Could you check the logs during the error happens, possibly there are clues there.


    0 0 0 0 0 0
    • That's the problem there are no errors, just the one listed. I only know this error because it shows in my litespeed web server logs and only occurs when doing the multiple uploads on the comment posts or timeline feed posts. I can upload 1 image or item without a problem. Only run into issue with multiple. If it was a permission issue It would not show after I refresh and the 1 image would not work. Id also receive an error, which I am not. Atleast I think. This is all in the post. 

      0 0 0 0 0 0
      • I am also on my own server but not having this problem.
        can you do a tail -f /var/log/litespeed/error.log ( or however it iserror log filename).
        may be it is passing very fast and not catched.

        0 0 0 0 0 0
        • The tail is matching up with my error logs in Litespeed webserver. This was realtime as I was uploading photos. The kill is when I am refreshing page. image_transcoder.php?o=bx_froala_image&h=2831&dpx=1&t=1580043499

          image_transcoder.php?o=bx_froala_image&h=2832&dpx=1&t=1580043587

          0 0 0 0 0 0
          • Debug while waiting on screen images are uploaded to.  image_transcoder.php?o=bx_froala_image&h=2833&dpx=1&t=1580043968

            0 0 0 0 0 0
            • well actually I couldnt understand the problem from these data ...

              0 0 0 0 0 0
              • Yeah, everything is processing like it should. I did notice something though when doing logs, I had to restart the web server due to the logs stopped processing after my debug. The logs in panel for UNA have no errors updated since way back when I migrated and only log really growing is the profiler. Settings all look good and no errors makes it a pain. The only error that is consistent is the marka.js.map error. Maybe I need to setup a symlink 0.0 Not sure

                0 0 0 0 0 0
                • marka.js.map error isn't related, you can safely ignore this error, .map file is loaded only when browser debug panel is open for more easy debug.

                  I suspect that it maybe be deadlock in the DB, are you using InnoDB by any chance ? if yes, then server need to be properly configured for InnoDB, in other case use MyISAM or its derivatives.  

                  0 0 0 0 0 0
                  • Alex T⚜️ MariaDB does not use all the sections in that post, but what it does allow I do have. Most with InnoDB with Maria seems automatic. It would not take my old MySQL for the # of CPU's and Deadlocks. Here is my my.cnf : 

                    [mysqld]

                    innodb_log_file_size=400M

                    innodb_flush_method=O_DIRECT

                    innodb_io_capacity=1000

                    innodb_old_blocks_time=1000

                    innodb_open_files=5000


                    key_buffer_size=64M

                    read_buffer_size=256K

                    read_rnd_buffer_size=256K

                    query_cache_size=256M

                    query_cache_limit=5M

                    query_cache_type=on

                    join_buffer_size=4M

                    sort_buffer_size=4M

                    max_heap_table_size=128M

                    tmp_table_size=1024M

                    table_open_cache=100000

                    table_definition_cache=4000

                    thread_cache_size=192


                    collation-server=utf8mb4_unicode_ci

                    init-connect='SET NAMES utf8mb4'

                    character-set-server=utf8mb4

                    If you know of the options for Maria a may be missing please share. 

                    image_transcoder.php?o=bx_froala_image&h=2848&dpx=1&t=1580289109INNODB LogINNODB Variables Update looks like for rollback for timeout there is only an on and off, so as of now I got 

                    innodb_stats_on_metadata=on

                    innodb_log_file_size=400M

                    innodb_flush_method=O_DIRECT

                    innodb_io_capacity=1000

                    innodb_old_blocks_time=1000

                    innodb_open_files=5000

                    innodb_buffer_pool_size=4096M

                    innodb_lock_wait_timeout=4

                    innodb_rollback_on_timeout=on

                    Maybe delete the extra stuff you do not mention? The others were some things others have mentioned in the CyberPanel community. Sooo it looks like my issue was database related. Looks like some things are different with InnoDB in Maria. For example this one innodb_rollback_on_timeout=on and this line does not exist: binlog_format = MIXED and transaction_isolation = READ-COMMITTED so these were what was throwing off my My.CNF when I deleted the other options. I didn't have to change my pool_instances because mine is on 8 by default.   Please still do share if I should remove any of these.  GOSH Dangit, nevermind it didnt work :( I just give up. 

                    0 0 0 0 0 0
                    • Alex T⚜️ here are my buffer variables and some others: 

                       Autoextend increment    64

                      innodb_autoinc_lock_mode    1

                      innodb_background_scrub_data_check_interval    3600

                      innodb_background_scrub_data_compressed    OFF

                      innodb_background_scrub_data_interval    604800

                      innodb_background_scrub_data_uncompressed    OFF

                      innodb_buf_dump_status_frequency    0

                      innodb_buffer_pool_dump_at_shutdown    OFF

                      innodb_buffer_pool_dump_now    OFF

                      innodb_buffer_pool_dump_pct    100

                      innodb_buffer_pool_filename    ib_buffer_pool

                      innodb_buffer_pool_instances    8

                      innodb_buffer_pool_load_abort    OFF

                      innodb_buffer_pool_load_at_startup    OFF

                      innodb_buffer_pool_load_now    OFF

                      innodb_buffer_pool_populate    OFF

                          Buffer pool size    4,096 MiB

                      innodb_change_buffer_max_size    25


                      innodb_ft_max_token_size    84

                      innodb_ft_min_token_size    3

                      innodb_ft_num_word_optimize    2000

                      innodb_ft_result_cache_limit    2000000000

                      innodb_ft_server_stopword_table    

                      innodb_ft_sort_pll_degree    2

                      innodb_ft_total_cache_size    640000000

                      innodb_ft_user_stopword_table    

                      innodb_idle_flush_pct    100

                      innodb_immediate_scrub_data_uncompressed    OFF

                      innodb_instrument_semaphores    OFF

                      innodb_io_capacity    1000

                      innodb_io_capacity_max    2000

                      innodb_kill_idle_transaction    0

                      innodb_large_prefix    OFF

                      innodb_lock_schedule_algorithm    fcfs

                      innodb_lock_wait_timeout    4

                      innodb_locking_fake_changes    ON

                      innodb_locks_unsafe_for_binlog    OFF

                      innodb_log_arch_dir    ./

                      innodb_log_arch_expire_sec    0

                      innodb_log_archive    OFF

                      innodb_log_block_size    512

                      innodb_log_buffer_size    16,384 KiB

                      innodb_log_checksum_algorithm    INNODB

                      innodb_log_compressed_pages    ON

                      innodb_log_file_size    410 k KiB

                      innodb_log_files_in_group    2

                      innodb_log_group_home_dir    ./


                      See Last Post that has my current InnoDB directives for variables. I am wondering if it could be my flushing option, not sure. So I got my other variable settings to work and deleted the ones I got elsewhere :/ testing now. So with just 

                      innodb_stats_on_metadata=off

                      innodb_log_file_size=400M

                      innodb_buffer_pool_size=4096M

                      innodb_lock_wait_timeout=4

                      innodb_rollback_on_timeout=on

                      transaction-isolation=READ-COMMITTED

                      binlog_format=MIXED

                      and clearing cache. this did not work. Yes before someone hops in and says so and hops out, I restarted Maria and Web Server, each time i made a change. I did from studio and from with the the web directory. Keep in mind Jquery is necessary when it comes to loading multiple images. Its not like they are not there. They upload, but do not show unless you refresh the page and then you have to post then refresh again. This also only happens when it is more then one image. Litespeed logs and bxprofiler show that the file is uploading without error.  I really do not think this is a database issue and there are no errors which has me in a loop, and it might very well be. All INNODB settings at this point unless something looks off in those variables, is as it should be based on what can be found here.  There are some extra InnoDB variables didnt see with my old MySQL when I was on Cpanel. What is so frustrating is for a moment I was able to do it and then not again. So it could still be database, but I cant be sure. At this point I am beyond frustration 🙀 

                      0 0 0 0 0 0
                      • We also have a similar situation on our website: Linguria.com We have to refresh the page after uploading an image to timeline. And, if we upload multiple images it may take 4 - 5 minutes to process all images. 

                        0 0 0 0 0 0
                        • even to show images take long time i think image also need to be compressed while uploading

                          0 0 0 0 0 0
                          • Hello UMIT OZAYDIN !

                            I could upload not several so small images fast on your site. But yes, I was needed to reload the page to see this my post. The reason is in some Javascript error, we're checking it.

                            0 0 0 0 0 0
                            • Thank you LeonidS 

                              0 0 0 0 0 0
                              • the same in outline when you update a post you have to refresh the page to show it

                                0 0 0 0 0 0
                                • Yeah anywhere you get the fields to upload the images. Everything else is fine. Before I moved over from Cpanel never had this issue. So I am sure it is something that is missing or not being read right. Still cant figure it out through my troubleshooting so hope someone can help us. 

                                  0 0 0 0 0 0
                                  • Some of the timeline blocks will get a correction of this trouble in UNA 11, but for now, you may activate the "Public Feed (Outline)" block. It shows the content instantly.

                                    0 0 0 0 0 0
                                    • That is exactly what I use for our homepage. Keep in mind the content uploads, it shows, but only after refreshing. This one happens with two or more photos and you refresh they show and then hit post and then refresh again and they show. This issue is with all areas that you can post to and attach content. What I do not understand is this issue was not present prior. So for me I find it hard to believe it will be fixed, but maybe I will be proven wrong. Before I moved this over we ran an event that made it so people had to upload multiple images to a timeline post in an event telling a story for a contest. It worked as intended. No longer there now since my timeline reinstall of course. The thing is I never tried posting new items since conversion so never noticed it was not working anymore until the day I asked for help. So unsure if this could have happened the day we reinstalled or from the beginning of conversion all together. So at a standstill at this time. Quick update to this *I tried all things emoticons, links, and Videos, and none of those have this issue only images.* I also tried without GD being I have imagemagick on back end and with GD library. We tried disabling caches. 

                                      0 0 0 0 0 0
                                      • Figured Id share this to in case this helps. Keep in mind this is my MYQL in a whole for buffering, but the main site is the social community: Also UNA shows I am on MYSQL5.5.5, but I am on Maria DB is this an issue? 

                                        Percona-XtraDB, Supports transactions, row-level locking, foreign keys and encryption for tables


                                        [ Variables | Buffer Pool | InnoDB Status ]


                                        Buffer Pool Usage

                                        Total : 262,136 pages / 4,096 MiB

                                        Free pages    257,917

                                        Dirty pages    0

                                        Pages containing data    4,198

                                        Pages to be flushed    3,567

                                        Busy pages    21

                                        Buffer Pool Activity

                                        Read requests    521,658

                                        Write requests    26,799

                                        Read misses    4,055

                                        Write waits    0

                                        Read misses in %    777.33 m %

                                        Write waits in %    0 %

                                        I also noticed that If you use the multi uploader  just uploading one at a time they will show without issues. So most definitely only when two or more images are uploaded together.  Alex T⚜️ 

                                        0 0 0 0 0 0
                                        • Kyle what is DB engine for your tables in UNA database ? also if you are using InnoDB or other similar DB engine with row-level locking, you need to specify it in inc/header.in.php as shown in this post along with all other DB settings.

                                          0 0 0 0 0 0
                                          • Sighs 😫 Please read my posts. Yes all this is set in my header inc and yes this is the engine it is set to. Nothing has changed in my conversion. You already sent me to this post. Every simple answer has already been dealt with or not an issue. This is far more than that. My site is live, it is running, it is reading and writing, just not multiple image uploads. You can use the multi uploader and do one at a time, but not 2 or 3 at a time without refreshing after. There are no errors to help troubleshoot. Only reason I am mentioning the database is because you brought it up so I checked it out. This has not resolved the issue unless MariaDB has extra options that need to be set for INNODB. I have shared all my findings in this post and what I have tried. I have already troubleshooted with Leonid S and he was unable to figure it out neither and referred it to you. I need real help.

                                            0 0 0 0 0 0
                                            • Kyle i am using Mariadb too without any problems.

                                              Can it be PHP max post size setting? How much is it in your server?

                                              0 0 0 0 0 0
                                              • It is in this post already, everything is in this post.  All my stuff is set high and I can uplaod videos, etc without a problem. Mine is set at 512. https://vybz.live/php.php  

                                                0 0 0 0 0 0
                                                • At this point, what I am going to do is try to convert over to Aria. Maybe it is an issue with InnoDB in connection with MariaDB in relation to UNA. If this does not resolve issue at this point it has to be something else. I wish I tested this before I reinstalled the timeline. It could very much be related to that, but now I will never know. Keep in mind guys everything was converted over to CyberPanel from Cpanel with same settings. Nothing has changed and it worked before. Only things that have changed are for example MariaDB instead of MySQL because CyberPanel is built on it. Also Litespeed uses LSPHP but same concept and everything is set really high there is no way at this point between switchign between different PHP version that PHP is the issue. I do feel it may be database related being it worked for a split second when I changed my Innodb settings in the My.CNF. So to I am going to try to convert database. Hopefully by the time Una evolves and does end up using transactions Aria will support it to. 


                                                  0 0 0 0 0 0
                                                  • İ had many problems with php7.2 and .3 and using 7.1 now, did you try with different PHP versions?

                                                    0 0 0 0 0 0
                                                    • Yes 

                                                      0 0 0 0 0 0
                                                      • İ don't think that it's related to Mariadb as i am using from the beginning without any problem.

                                                        But better to test.

                                                        0 0 0 0 0 0
                                                        • Finally!!!!! Somehow I always end up fixing it my own way. So changing to Aria has resolved the issue. There has to be an INNODB option that cause an issue but not sure at this time. Everything was the same though. At the time I will stick with Aria. Keep in mind trying Alex's fix for for did not work on for me. I would advise at this point unless tested and a resolution, do not use INNODB, but use or engines instead if you use MariaDB. If you have a fix please share.

                                                          0 0 0 0 0 0
                                                          • It's great that you made it work with Aria DB engine, I think that UNA wasn't working with InnoDB in your case, because you had incorrect setting for transaction_isolation option, which you said you wasn't able to specify. I think for MariaDB this setting should be named tx_isolation instead of transaction_isolation

                                                            0 0 0 0 0 0
                                                            Not logged in users can't 'Comments Post'.
                                                            Added:
                                                            Category:

                                                            UNA - Social Media Software Framework

                                                            Close