•  · 13 friends

After update to UNA 12.0.1 http error 500

Hi folks! Just updated to 12.0.1 and cannot access Studio anymore. I get a http error 500 (pic attached). Checked back on my web server, but there's everything ok.

Cheers, thomlin

0 0 0 0 0 0
  • 365
Attachments
Replies (38)
  • It should be update for Timeline module with this fix within hours, if the fix is needed urgently or update can't be applied for some reason, then please apply the following manually:

    https://github.com/unaio/una/commit/6eba2618c07bcb4450d2a9370637a3cbf810d891

    0 0 0 0 0 0
    • Do you read update logs?

      0 0 0 0 0 0
      •  u cleared the caches on ur server under folder   cache and public_cache and in ur browser?! Most time it fix this 500 ERROR 

        0 0 0 0 0 0
        • Yes, I cleared all the caches before I got locked out.

          0 0 0 0 0 0
          • Nothing unusual here:

            --------- 2021-03-04T21:40:01+00:00

            12.0.0-12.0.1 upgrade will be applied

            Files permissions are ok and can be overwritten

            Files copying successfully completed

            Deprecated files were successfully deleted or there is no files to delete

            System files hash was successfully updated

            System SQL script was successfully executed

            The following languages will be affected for system:

             - No languages will be affected

            System after update custom script was successfully executed

            0 0 0 0 0 0
            • Also normal aufrufen kann man deine Seite aber ...


              0 0 0 0 0 0
              • wie hast du den Cache denn gelöscht? über den server also FTP oder über dein Dashboard

                0 0 0 0 0 0
                • Only the backend (Studio), frontend is ok.

                  0 0 0 0 0 0
                  • Über das Dashboard. Bin gerade dabei, die Dateien im Cache zu sichern und noch einmal manuell zu löschen.

                    0 0 0 0 0 0
                    • Aslo ich lösche immer manuell weil ich das Gefühl habe das er mir über das Dashboard den Cache nie richtig leert

                      0 0 0 0 0 0
                      • Der Versuch war's wert. Hat leider das Problem nicht gelöst.

                        0 0 0 0 0 0
                        • I have two sites and since updating to version 12.01 I can't access my studio. I've cleared all caches.

                          0 0 0 0 0 0
                          • Having same exact problem! Except i did not update to 12.0.1 i cant double check as i cant access studio to check however i should still be on 12.0.0

                            There are now 2 threads going with a problem acessing studios with reports from multiple members.

                            Admin? LeonidS Alex T⚜️ 



                            0 0 0 0 0 0
                            • Hello. 500 is internal server error. In this case you need to check server's log file (error.log) to get more detailed description of the problem. The exact place of the log file may vary depending on your server software and configuration settings.

                              0 0 0 0 0 0
                              • I am getting the exact same error message as the poster of this thread:

                                https://una.io/page/view-discussion?id=7540

                                This is looking like a UNA problem.

                                0 0 0 0 0 0
                                • Hello.

                                  The issue can be fixed if you Disable/Enable the Timeline app.
                                  Note. If you customized Timeline's blocks/menus/settings they will be restored to the default state.

                                  In most cases this solution doesn't help. 

                                  0 0 0 0 0 0
                                  • Hi Anton, Thank for reply but I'm pretty sure i done some customizing.  I would prefer not to lose anything.  Especially when I have know idea to what extent things would be reverted.  Maybe as a last resort if that is indeed a solution or only solution.


                                    Would like to first  know what is the cause of this? Is it just me and three other members? Do we have something in common?  TDMHosting?


                                    The others seems to have upgraded to 12.0.1.  I am not aware of my site having been updated, it not something I did but am checking with to TMD.


                                    Is someone on the UNA team looking into this?

                                    0 0 0 0 0 0
                                    • I cannot reproduce the issue on my Dev site. But if you provide me with FTP and Studio access info (via PM) I'll check it directly on your site.

                                      0 0 0 0 0 0
                                      • I am experiencing the same challenge. Can't do anything. Having error 500 after upgrade to 12.0.1

                                        0 0 0 0 0 0
                                        • Thanks to thomlin for provided access info.

                                          0 0 0 0 0 0
                                          • Thanks for fixing it, Anton L!

                                            0 0 0 0 0 0
                                            • You are welcome!

                                              0 0 0 0 0 0
                                              • Tmd doesnt have ftp anymore. Any other way to give accsss? 

                                                0 0 0 0 0 0
                                                • Yes, PopAllure , just provide the Control Panel access details, usually there exists the File manager.

                                                  0 0 0 0 0 0
                                                  • It should be update for Timeline module with this fix within hours, if the fix is needed urgently or update can't be applied for some reason, then please apply the following manually:

                                                    https://github.com/unaio/una/commit/6eba2618c07bcb4450d2a9370637a3cbf810d891

                                                    0 0 0 0 0 0
                                                    • Thanks so much Anton L .

                                                      0 0 0 0 0 0
                                                      • You are welcome!

                                                        0 0 0 0 0 0
                                                        • Having same exact problem! Except i did not update to 12.0.1 i cant double check as i cant access studio to check however i should still be on 12.0.0

                                                          There are now 2 threads going with a problem acessing studios with reports from multiple members.

                                                          Admin?



                                                          Same here. I have version 11 initially installed (and I still do) but for some reason I got a admin email saying the modules have upgraded to v12. (And a couple modules failed as well)

                                                          0 0 0 0 0 0
                                                          • I would love to get directions as to what steps I should take to correct this same issue. Thank you so much, I love UNA.

                                                            0 0 0 0 0 0
                                                            • Hello, 

                                                              Greeting


                                                              Go to cpanel or FTP find the modules / boonex / timeline / classes / BxTimelineTemplate.php file


                                                              Below $ this -> _ aAclId2Name = array ();


                                                              leave one row blank


                                                              And put this bx_import ('BxTemplAcl');


                                                              - Save this change


                                                              0 0 0 0 0 0
                                                              • Same problem here. Don't have file access, because my site is on UNA cloud. Can you please fix this?

                                                                0 0 0 0 0 0
                                                                • Same problem here. Don't have file access, because my site is on UNA cloud. Can you please fix this?

                                                                  I've just fixed it on your site

                                                                  0 0 0 0 0 0
                                                                  • Is it safe upgrading to 12.0.1 from 12.0.0 or not?

                                                                    0 0 0 0 0 0
                                                                    • Now - yes. just don't forget to update all modules after.

                                                                      0 0 0 0 0 0
                                                                      • Thank you I will try this ! I am just now seeing the github link to this. Thank you for taking time to write it out!

                                                                        0 0 0 0 0 0
                                                                        • Have the same HTTP ERROR 500 issue.  There's twenty different answers, on this discussion, to fix problem.  What is the correct solution?


                                                                          0 0 0 0 0 0
                                                                          • I swapped the BxTimlineTemplate.php with the one Alex T provided on this discussion and it works now.

                                                                            0 0 0 0 0 0
                                                                            • Another HTTP Error 500 issue I had was a cache issue

                                                                              1.  Go to FTP and look up what the error may be in the errorlog.  

                                                                              2. My issue shown cache errors

                                                                              3. I Logged to Cpanel then File Manager and clear out cache folder (leaving the sub folders intact) and then cleared public cache folder.

                                                                              4. Site was up and running again.

                                                                              0 0 0 0 0 0
                                                                              • Thanks Alex T⚜️ today I had the same problem and I was able to solve with this.

                                                                                0 0 0 0 0 0
                                                                                Not logged in users can't 'Comments Post'.
                                                                                7
                                                                                1
                                                                                1
                                                                                1
                                                                                1
                                                                                Labels:
                                                                                Added:
                                                                                Category:

                                                                                UNA - Network Infrastructure for Communities

                                                                                Close